VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,541)

page 2005 of 2,428
  • CVE-2020-5269MedApr 20, 2020
    risk 0.20cvss 4.1epss 0.01

    In PrestaShop between versions 1.7.6.1 and 1.7.6.5, there is a reflected XSS on AdminFeatures page by using the `id_feature` parameter. The problem is fixed in 1.7.6.5

  • CVE-2020-5273MedApr 16, 2020
    risk 0.20cvss 4.1epss 0.01

    In PrestaShop module ps_linklist versions before 3.1.0, there is a stored XSS when using custom URLs. The problem is fixed in version 3.1.0

  • CVE-2020-5283LowApr 3, 2020
    risk 0.20cvss 3.1epss 0.01

    ViewVC before versions 1.1.28 and 1.2.1 has a XSS vulnerability in CVS show_subdir_lastmod support. The impact of this vulnerability is mitigated by the need for an attacker to have commit privileges to a CVS repository exposed by an otherwise trusted ViewVC instance that also…

  • CVE-2017-2607MedMay 21, 2018
    risk 0.20cvss 4.2epss 0.01

    jenkins before versions 2.44, 2.32.2 is vulnerable to a persisted cross-site scripting vulnerability in console notes (SECURITY-382). Jenkins allows plugins to annotate build logs, adding new content or changing the presentation of existing content while the build is running.…

  • CVE-2025-8550LowAug 5, 2025
    risk 0.19cvss 2.4epss 0.01

    A vulnerability was found in atjiu pybbs up to 6.0.0. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /admin/topic/list. The manipulation of the argument Username leads to cross site scripting. The attack can be…

  • CVE-2025-30081medMar 19, 2025
    risk 0.19cvss —epss 0.01

    A cross-site scripting (XSS) vulnerability has been discovered in the Clickstorm SEO extension. This vulnerabily is exploitable by a logged in backend user utilizing the TYPO3 backend user interface. This user can create output in the HTML context by exploiting improperly…

  • CVE-2024-11954LowJan 28, 2025
    risk 0.19cvss 2.4epss 0.01

    A vulnerability classified as problematic was found in Pimcore 11.4.2. Affected by this vulnerability is an unknown functionality of the component Search Document. The manipulation leads to basic cross site scripting. The attack can be launched remotely. The exploit has been…

  • CVE-2024-7815LowAug 15, 2024
    risk 0.19cvss 2.4epss 0.01

    A vulnerability has been found in CodeAstro Online Railway Reservation System 1.0 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file /admin/admin-update-employee.php of the component Update Employee Page. The manipulation of the…

  • CVE-2024-7388MedAug 13, 2024
    risk 0.19cvss 4.0epss 0.00

    The WP Bannerize Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via banner alt data in all versions up to, and including, 1.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…

  • CVE-2024-37161MedJun 11, 2024
    risk 0.19cvss 4.0epss 0.00

    MeterSphere is an open source continuous testing platform. Prior to version 1.10.1-lts, the system's step editor stores cross-site scripting vulnerabilities. Version 1.10.1-lts fixes this issue.

  • CVE-2024-28237MedMar 18, 2024
    risk 0.19cvss 4.0epss 0.00

    OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.9.3 contain a vulnerability that allows malicious admins to configure or talk a victim with administrator rights into configuring a webcam snapshot URL which when…

  • CVE-2023-3184LowJun 9, 2023
    risk 0.19cvss 2.4epss 0.02

    A vulnerability was found in SourceCodester Sales Tracker Management System 1.0. It has been rated as problematic. Affected by this issue is some unknown functionality of the file /classes/Users.php?f=save. The manipulation of the argument firstname/middlename/lastname/username…

  • CVE-2018-25080LowFeb 4, 2023
    risk 0.19cvss 3.5epss 0.03

    A vulnerability, which was classified as problematic, has been found in MobileDetect 2.8.31. This issue affects the function initLayoutType of the file examples/session_example.php of the component Example. The manipulation of the argument $_SERVER['PHP_SELF'] leads to cross…

  • CVE-2022-26325LowMay 2, 2022
    risk 0.19cvss 2.9epss 0.00

    Reflected Cross Site Scripting (XSS) vulnerability in NetIQ Access Manager prior to 5.0.2

  • CVE-2013-7035medSep 4, 2020
    risk 0.19cvss —epss 0.02

    Affected versions of `react` are vulnerable to Cross-Site Scripting (XSS). The package fails to properly sanitize input used to create keys. This may allow attackers to execute arbitrary JavaScript if a key is generated from user input. ## Recommendation If you are using…

  • CVE-2016-1000240medSep 1, 2020
    risk 0.19cvss —epss 0.01

    Affected versions of `c3` are vulnerable to cross-site scripting via improper sanitization of HTML in rendered tooltips. ## Recommendation Update to 0.4.11 or later.

  • CVE-2020-5298MedJun 3, 2020
    risk 0.19cvss 4.0epss 0.01

    In OctoberCMS (october/october composer package) versions from 1.0.319 and before 1.0.466, a user with the ability to use the import functionality of the `ImportExportController` behavior can be socially engineered by an attacker to upload a maliciously crafted CSV file which…

  • CVE-2020-5267MedMar 19, 2020
    risk 0.19cvss 4.0epss 0.02

    In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

  • CVE-2026-27964LowMay 18, 2026
    risk 0.18cvss 3.9epss 0.00

    FacturaScripts is an open source accounting and invoicing software. Versions 2025.7 and prior contain a Reflected Cross-Site Scripting (XSS) vulnerability through the fsNick cookie parameter. The application reflects the cookie's value directly into the HTML without…

  • CVE-2026-3495LowMay 18, 2026
    risk 0.18cvss 3.8epss 0.00

    Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13 fail to escape some variables that could contain malicious content during error page composition which allows an attacker with access to edit some site configuration to execute some malicious code via injecting some JS as…