VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,541)

page 2006 of 2,428
  • CVE-2025-64711LowNov 13, 2025
    risk 0.18cvss 3.9epss 0.00

    PrivateBin is an online pastebin where the server has zero knowledge of pasted data. Starting in version 1.7.7 and prior to version 2.0.3, dragging a file whose filename contains HTML is reflected verbatim into the page via the drag-and-drop helper, so any user who drops a…

  • CVE-2025-62412LowOct 16, 2025
    risk 0.18cvss 3.8epss 0.00

    LibreNMS is a community-based GPL-licensed network monitoring system. The alert rule name in the Alerts > Alert Rules page is not properly sanitized, and can be used to inject HTML code. This vulnerability is fixed in 25.10.0.

  • CVE-2025-22855LowApr 8, 2025
    risk 0.18cvss 2.7epss 0.00

    An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability in Fortinet FortiClient before 7.4.1 may allow the EMS administrator to send messages containing javascript code.

  • CVE-2024-13116LowJan 27, 2025
    risk 0.18cvss 3.8epss 0.00

    The Crelly Slider WordPress plugin before 1.4.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite…

  • CVE-2024-10562LowJan 7, 2025
    risk 0.18cvss 2.7epss 0.00

    The Form Maker by 10Web WordPress plugin before 1.15.31 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in…

  • CVE-2024-10102LowJan 7, 2025
    risk 0.18cvss 2.7epss 0.01

    The Photo Gallery, Images, Slider in Rbs Image Gallery WordPress plugin before 3.2.22 does not sanitise and escape some of its Gallery settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks

  • CVE-2024-37253LowJul 9, 2024
    risk 0.18cvss 2.7epss 0.00

    Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection') vulnerability in WpDirectoryKit WP Directory Kit allows Code Injection.This issue affects WP Directory Kit: from n/a through 1.3.6.

  • CVE-2024-35239LowMay 28, 2024
    risk 0.18cvss 2.7epss 0.00

    Umbraco Commerce is an open source dotnet web forms solution. In affected versions an authenticated user that has access to edit Forms may inject unsafe code into Forms components. This issue can be mitigated by configuring TitleAndDescription:AllowUnsafeHtmlRendering after…

  • CVE-2023-46126LowOct 25, 2023
    risk 0.18cvss 3.9epss 0.01

    Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in runtime environments, helping enforce privacy regulations in code. The Fides web application allows users to edit consent and privacy notices such as cookie banners. The…

  • CVE-2023-5631MedKEVOct 18, 2023
    risk 0.18cvss 6.1epss 0.77

    Roundcube before 1.4.15, 1.5.x before 1.5.5, and 1.6.x before 1.6.4 allows stored XSS via an HTML e-mail message with a crafted SVG document because of program/lib/Roundcube/rcube_washtml.php behavior. This could allow a remote attacker to load arbitrary JavaScript code.

  • CVE-2022-26888LowFeb 16, 2023
    risk 0.18cvss 2.8epss 0.00

    Cross-site scripting in the Intel(R) Quartus Prime Pro and Standard edition software may allow an authenticated user to potentially enable information disclosure via local access.

  • CVE-2022-2826LowOct 28, 2022
    risk 0.18cvss 2.7epss 0.01

    An issue has been discovered in GitLab affecting all versions starting from 10.0 before 12.9.8, all versions starting from 12.10 before 12.10.7, all versions starting from 13.0 before 13.0.1. TODO

  • CVE-2022-2256LowSep 1, 2022
    risk 0.18cvss 3.8epss 0.01

    A Stored Cross-site scripting (XSS) vulnerability was found in keycloak as shipped in Red Hat Single Sign-On 7. This flaw allows a privileged attacker to execute malicious scripts in the admin console, abusing the default roles functionality.

  • CVE-2022-29816LowApr 28, 2022
    risk 0.18cvss 2.8epss 0.00

    In JetBrains IntelliJ IDEA before 2022.1 HTML injection into IDE messages was possible

  • CVE-2017-9275LowApr 26, 2018
    risk 0.18cvss 2.8epss 0.01

    NetIQ Identity Reporting, in versions prior to 5.5 Service Pack 1, is susceptible to an XSS attack.

  • CVE-2018-0532LowApr 16, 2018
    risk 0.18cvss 2.7epss 0.01

    Cybozu Garoon 3.0.0 to 4.2.6 allows remote authenticated attackers to bypass access restriction to alter setting data of the Standard database via unspecified vectors.

  • CVE-2017-9441LowJun 5, 2017
    risk 0.18cvss 2.7epss 0.01

    Multiple cross-site scripting (XSS) vulnerabilities in BigTree CMS through 4.2.18 allow remote authenticated users to inject arbitrary web script or HTML by uploading a crafted package, triggering mishandling of the (1) title or (2) version or (3) author_name parameter in…

  • CVE-2016-0370LowSep 1, 2016
    risk 0.18cvss 2.7epss 0.01

    Cross-site scripting (XSS) vulnerability in IBM Forms Experience Builder 8.5.x and 8.6.x before 8.6.3 allows remote authenticated users to inject arbitrary web script or HTML via crafted input to an application that was built with this product.

  • CVE-2026-113657LowOct 20, 2026
    risk 0.17cvss 3.7epss 0.00

    ApostropheCMS is an open-source Node.js content management system, and sanitize-html provides a simple HTML sanitizer with a clear API. From sanitize-html 2.17.7 until 2.18.0, an application configuration that permits namespace-prefixed SVG animation elements and the relevant…

  • CVE-2026-100881LowSep 27, 2026
    risk 0.17cvss 2.6epss 0.00

    A security vulnerability has been detected in zhistaredu StarTraining up to 3.8.1. This issue affects some unknown processing of the file application.yml. Such manipulation of the argument xss.enabled leads to cross site scripting. It is possible to launch the attack remotely.…