VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,541)

page 2004 of 2,428
  • CVE-2023-37529LowFeb 29, 2024
    risk 0.20cvss 3.0epss 0.00

    A cross-site scripting (XSS) vulnerability in the Web Reports component of HCL BigFix Platform can possibly allow an attacker to execute malicious javascript code into a webpage trying to retrieve cookie stored information. This is not the same vulnerability as identified in…

  • CVE-2024-23553LowFeb 2, 2024
    risk 0.20cvss 3.0epss 0.00

    A cross-site scripting (XSS) vulnerability in the Web Reports component of HCL BigFix Platform exists due to missing a specific http header attribute.

  • CVE-2023-41813LowDec 29, 2023
    risk 0.20cvss 3.0epss 0.00

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Pandora FMS on all allows Cross-Site Scripting (XSS). Allows you to edit the Web Console user notification options. This issue affects Pandora FMS: from 700 through 774.

  • CVE-2023-5496LowOct 10, 2023
    risk 0.20cvss 3.1epss 0.01

    A vulnerability was found in Translator PoqDev Add-On 1.0.11 on Firefox. It has been rated as problematic. This issue affects some unknown processing of the component Select Text Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The…

  • CVE-2023-37875LowSep 12, 2023
    risk 0.20cvss 3.0epss 0.00

    Improper encoding or escaping of output in Wing FTP Server (User Web Client) allows Cross-Site Scripting (XSS).This issue affects Wing FTP Server: <= 7.2.0.

  • CVE-2023-41318MedSep 8, 2023
    risk 0.20cvss 4.1epss 0.01

    matrix-media-repo is a highly customizable multi-domain media repository for the Matrix chat ecosystem. In affected versions an attacker could upload a malicious piece of media to the media repo, which would then be served with `Content-Disposition: inline` upon download. This…

  • CVE-2023-4709LowSep 1, 2023
    risk 0.20cvss 3.1epss 0.00

    A vulnerability classified as problematic has been found in TOTVS RM 12.1. Affected is an unknown function of the file Login.aspx of the component Portal. The manipulation of the argument VIEWSTATE leads to cross site scripting. It is possible to launch the attack remotely. The…

  • CVE-2023-3862LowJul 24, 2023
    risk 0.20cvss 3.1epss 0.00

    A vulnerability was found in Travelmate Travelable Trek Management Solution 1.0. It has been rated as problematic. Affected by this issue is some unknown functionality of the component Comment Box Handler. The manipulation of the argument comment leads to cross site scripting.…

  • CVE-2023-32024LowJun 14, 2023
    risk 0.20cvss 3.0epss 0.01

    Microsoft Power Apps Spoofing Vulnerability

  • CVE-2022-33994LowJul 30, 2022
    risk 0.20cvss 3.0epss 0.01

    The Gutenberg plugin through 13.7.3 for WordPress allows stored XSS by the Contributor role via an SVG document to the "Insert from URL" feature. NOTE: the XSS payload does not execute in the context of the WordPress instance's domain; however, analogous attempts by…

  • CVE-2022-0167LowJul 1, 2022
    risk 0.20cvss 3.1epss 0.01

    An issue has been discovered in GitLab affecting all versions starting from 14.0 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was not disabling the Autocomplete attribute of fields related to sensitive…

  • CVE-2022-31108MedJun 28, 2022
    risk 0.20cvss 4.1epss 0.01

    Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. An attacker is able to inject arbitrary `CSS` into the generated graph allowing them to change the styling of elements…

  • CVE-2021-23285LowApr 18, 2022
    risk 0.20cvss 3.1epss 0.00

    Eaton Intelligent Power Manager Infrastructure (IPM Infrastructure) version 1.5.0plus205 and all prior versions are vulnerable to reflected Cross-site Scripting vulnerability. This issue affects: Eaton Intelligent Power Manager Infrastructure (IPM Infrastructure) all version…

  • CVE-2022-25613MedApr 4, 2022
    risk 0.20cvss 4.1epss 0.01

    Authenticated Persistent Cross-Site Scripting (XSS) vulnerability in FV Flowplayer Video Player (WordPress plugin) versions <= 7.5.18.727 via &fv_wp_flowplayer_field_splash parameter.

  • CVE-2021-23472LowNov 3, 2021
    risk 0.20cvss 3.1epss 0.02

    This affects versions before 1.19.1 of package bootstrap-table. A type confusion vulnerability can lead to a bypass of input sanitization when the input provided to the escapeHTML function is an array (instead of a string) even if the escape attribute is set.

  • CVE-2021-32792LowJul 26, 2021
    risk 0.20cvss 3.1epss 0.02

    mod_auth_openidc is an authentication/authorization module for the Apache 2.x HTTP server that functions as an OpenID Connect Relying Party, authenticating users against an OpenID Connect Provider. In mod_auth_openidc before version 2.4.9, there is an XSS vulnerability in when…

  • CVE-2021-32719LowJun 28, 2021
    risk 0.20cvss 3.1epss 0.01

    RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the `rabbitmq_federation_management` plugin, its consumer tag was rendered without proper tag sanitization.…

  • CVE-2021-32718LowJun 28, 2021
    risk 0.20cvss 3.1epss 0.01

    RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.17, a new user being added via management UI could lead to the user's bane being rendered in a confirmation message without proper `` tag sanitization, potentially allowing for…

  • CVE-2020-5272MedApr 20, 2020
    risk 0.20cvss 4.1epss 0.01

    In PrestaShop between versions 1.5.5.0 and 1.7.6.5, there is a reflected XSS on Search page with `alias` and `search` parameters. The problem is patched in 1.7.6.5

  • CVE-2020-5271MedApr 20, 2020
    risk 0.20cvss 4.1epss 0.01

    In PrestaShop between versions 1.6.0.0 and 1.7.6.5, there is a reflected XSS with `date_from` and `date_to` parameters in the dashboard page This problem is fixed in 1.7.6.5