VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1622 of 2,429
  • CVE-2024-40101MedAug 6, 2024
    risk 0.33cvss 6.1epss 0.01

    A Reflected Cross-site scripting (XSS) vulnerability exists in '/search' in microweber 2.0.15 and earlier allowing unauthenticated remote attackers to inject arbitrary web script or HTML via the 'keywords' parameter.

  • CVE-2024-41810MedJul 29, 2024
    risk 0.33cvss 6.1epss 0.01

    Twisted is an event-based framework for internet applications, supporting Python 3.6+. The `twisted.web.util.redirectTo` function contains an HTML injection vulnerability. If application code allows an attacker to control the redirect URL this vulnerability may result in…

  • CVE-2024-41805MedJul 26, 2024
    risk 0.33cvss 6.1epss 0.00

    Tracks, a Getting Things Done (GTD) web application, is vulnerable to reflected cross-site scripting in versions prior to 2.7.1. Reflected cross-site scripting enables execution of malicious JavaScript in the context of a user’s browser if that user clicks on a malicious link,…

  • CVE-2024-38739MedJul 20, 2024
    risk 0.33cvss 5.1epss 0.00

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in FameThemes OnePress allows Stored XSS.This issue affects OnePress: from n/a through 2.3.8.

  • CVE-2024-5062MedJun 30, 2024
    risk 0.33cvss 6.1epss 0.00

    A reflected Cross-Site Scripting (XSS) vulnerability was identified in zenml-io/zenml version 0.57.1. The vulnerability exists due to improper neutralization of input during web page generation, specifically within the survey redirect parameter. This flaw allows an attacker to…

  • CVE-2024-5889MedJun 29, 2024
    risk 0.33cvss 6.1epss 0.00

    The Events Manager – Calendar, Bookings, Tickets, and more! plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘country’ parameter in all versions up to, and including, 6.4.8 due to insufficient input sanitization and output escaping. This makes…

  • CVE-2024-21520MedJun 26, 2024
    risk 0.33cvss 6.1epss 0.01

    Versions of the package djangorestframework before 3.15.2 are vulnerable to Cross-site Scripting (XSS) via the break_long_headers template filter due to improper input sanitization before splitting and joining with tags.

  • CVE-2024-4899MedJun 24, 2024
    risk 0.33cvss 5.0epss 0.00

    The SEOPress WordPress plugin before 7.8 does not sanitise and escape some of its Post settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks.

  • CVE-2024-38357MedJun 19, 2024
    risk 0.33cvss 6.1epss 0.01

    TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This…

  • CVE-2024-38356MedJun 19, 2024
    risk 0.33cvss 6.1epss 0.01

    TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content extraction code. When using the `noneditable_regexp` option, specially crafted HTML attributes containing malicious code were able to be executed when…

  • CVE-2024-37629MedJun 12, 2024
    risk 0.33cvss 6.1epss 0.00

    SummerNote v0.9.1 is vulnerable to Cross Site Scripting (XSS) via the Code View Function.

  • CVE-2024-37178MedJun 11, 2024
    risk 0.33cvss 5.0epss 0.00

    SAP Financial Consolidation does not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability. These endpoints are exposed over the network. The vulnerability can exploit resources beyond the vulnerable component. On successful…

  • CVE-2024-37156MedJun 6, 2024
    risk 0.33cvss 6.1epss 0.00

    The SuluFormBundle adds support for creating dynamic forms in Sulu Admin. The TokenController get parameter formName is not sanitized in the returned input field which leads to XSS. This vulnerability is fixed in 2.5.3.

  • CVE-2024-32464MedJun 4, 2024
    risk 0.33cvss 6.1epss 0.00

    Action Text brings rich text content and editing to Rails. Instances of ActionText::Attachable::ContentAttachment included within a rich_text_area tag could potentially contain unsanitized HTML. This vulnerability is fixed in 7.1.3.4 and 7.2.0.beta2.

  • CVE-2024-37031MedJun 3, 2024
    risk 0.33cvss 6.1epss 0.00

    The Active Admin (aka activeadmin) framework before 3.2.2 for Ruby on Rails allows stored XSS in certain situations where users can create entities (to be later edited in forms) with arbitrary names, aka a "dynamic form legends" issue. 4.0.0.beta7 is also a fixed version.

  • CVE-2024-33997MedMay 31, 2024
    risk 0.33cvss 6.1epss 0.00

    Additional sanitizing was required when opening the equation editor to prevent a stored XSS risk when editing another user's equation.

  • CVE-2024-25976MedMay 29, 2024
    risk 0.33cvss 6.1epss 0.01

    When LDAP authentication is activated in the configuration it is possible to obtain reflected XSS execution by creating a custom URL that the victim only needs to open in order to execute arbitrary JavaScript code in the victim's browser. This is due to a fault in the file…

  • CVE-2023-6844MedMay 23, 2024
    risk 0.33cvss 5.0epss 0.00

    The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcode(s) in all versions up to and including 5.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated…

  • CVE-2024-2119MedMay 22, 2024
    risk 0.33cvss 6.1epss 0.00

    The LuckyWP Table of Contents plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the attrs parameter in all versions up to, and including, 2.1.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers…

  • CVE-2024-36043MedMay 18, 2024
    risk 0.33cvss 6.1epss 0.00

    question_image.ts in SurveyJS Form Library before 1.10.4 allows contentMode=youtube XSS via the imageLink property.