VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1621 of 2,429
  • CVE-2024-45613MedSep 25, 2024
    risk 0.33cvss 6.1epss 0.01

    CKEditor 5 is a JavaScript rich-text editor. Starting in version 40.0.0 and prior to version 43.1.1, a Cross-Site Scripting (XSS) vulnerability is present in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to…

  • CVE-2024-8741MedSep 25, 2024
    risk 0.33cvss 6.1epss 0.00

    The Beam me up Scotty – Back to Top Button plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.0.21. This makes it possible for unauthenticated…

  • CVE-2024-8716MedSep 24, 2024
    risk 0.33cvss 6.1epss 0.00

    The XT Ajax Add To Cart for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.1.2. This makes it possible for unauthenticated attackers…

  • CVE-2024-8662MedSep 24, 2024
    risk 0.33cvss 6.1epss 0.00

    The Koko Analytics plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.3.12. This makes it possible for unauthenticated attackers to inject arbitrary…

  • CVE-2024-47069MedSep 23, 2024
    risk 0.33cvss 6.1epss 0.00

    Oveleon Cookie Bar is a cookie bar is for the Contao Open Source CMS and allows a visitor to define cookie & privacy settings for the website. Prior to versions 1.16.3 and 2.1.3, the `block/locale` endpoint does not properly sanitize the user-controlled `locale` input before…

  • CVE-2024-47068MedSep 23, 2024
    risk 0.33cvss 6.1epss 0.01

    Rollup is a module bundler for JavaScript. Versions prior to 2.79.2, 3.29.5, and 4.22.4 are susceptible to a DOM Clobbering vulnerability when bundling scripts with properties from `import.meta` (e.g., `import.meta.url`) in `cjs`/`umd`/`iife` format. The DOM Clobbering gadget…

  • CVE-2024-45803MedSep 17, 2024
    risk 0.33cvss 6.1epss 0.00

    Wire UI is a library of components and resources to empower Laravel and Livewire application development. A potential Cross-Site Scripting (XSS) vulnerability has been identified in the `/wireui/button` endpoint, specifically through the `label` query parameter. Malicious actors…

  • CVE-2024-8731MedSep 13, 2024
    risk 0.33cvss 6.1epss 0.00

    The Cron Jobs plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.2.9. This makes it possible for unauthenticated attackers to inject arbitrary web…

  • CVE-2024-8714MedSep 13, 2024
    risk 0.33cvss 6.1epss 0.00

    The WordPress Affiliates Plugin — SliceWP Affiliates plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of remove_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.1.20. This makes it possible for…

  • CVE-2024-8656MedSep 13, 2024
    risk 0.33cvss 6.1epss 0.00

    The WPFactory Helper plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 1.7.0. This makes it possible for unauthenticated attackers to inject arbitrary…

  • CVE-2024-8622MedSep 12, 2024
    risk 0.33cvss 6.1epss 0.00

    The amCharts: Charts and Maps plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'amcharts_javascript' parameter in all versions up to, and including, 1.4.4 due to the ability to supply arbitrary JavaScript a lack of nonce validation on the preview…

  • CVE-2024-45595MedSep 10, 2024
    risk 0.33cvss 6.1epss 0.01

    D-Tale is a visualizer for Pandas data structures. Users hosting D-Tale publicly can be vulnerable to remote code execution allowing attackers to run malicious code on the server. Users should upgrade to version 3.14.1 where the "Custom Filter" input is turned off by default.

  • CVE-2024-38858MedSep 2, 2024
    risk 0.33cvss 6.1epss 0.00

    Improper neutralization of input in Checkmk before version 2.3.0p14 allows attackers to inject and run malicious scripts in the Robotmk logs view.

  • CVE-2024-8274MedAug 30, 2024
    risk 0.33cvss 6.1epss 0.01

    The WP Booking Calendar plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via several parameters from 'timeline_obj' in all versions up to, and including, 10.5 due to insufficient input sanitization and output escaping. This makes it possible for…

  • CVE-2024-41349MedAug 29, 2024
    risk 0.33cvss 6.1epss 0.00

    unmark 1.9.2 is vulnerable to Cross Site Scripting (XSS) via application/views/marks/add_by_url.php.

  • CVE-2024-41348MedAug 29, 2024
    risk 0.33cvss 6.1epss 0.00

    openflights commit 5234b5b is vulnerable to Cross-Site Scripting (XSS) via php/alsearch.php

  • CVE-2024-41347MedAug 29, 2024
    risk 0.33cvss 6.1epss 0.00

    openflights commit 5234b5b is vulnerable to Cross-Site Scripting (XSS) via php/settings.php

  • CVE-2023-6987MedAug 24, 2024
    risk 0.33cvss 6.1epss 0.00

    The String locator plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'sql-column' parameter in all versions up to, and including, 2.6.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to…

  • CVE-2024-41937MedAug 21, 2024
    risk 0.33cvss 6.1epss 0.02

    Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user…

  • CVE-2024-43407MedAug 21, 2024
    risk 0.33cvss 6.1epss 0.00

    CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A potential vulnerability has been discovered in CKEditor 4 Code Snippet GeSHi plugin. The vulnerability allowed a reflected XSS attack by exploiting a flaw in the GeSHi syntax highlighter library hosted by…