VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1623 of 2,429
  • CVE-2024-2619MedMay 16, 2024
    risk 0.33cvss 5.0epss 0.00

    The Elementor Header & Footer Builder for WordPress is vulnerable to HTML Injection in all versions up to, and including, 1.6.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level permissions and…

  • CVE-2024-4150MedMay 14, 2024
    risk 0.33cvss 6.1epss 0.01

    The Simple Basic Contact Form plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘scf_email’ parameter in versions up to, and including, 20221201 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated…

  • CVE-2024-4041MedMay 14, 2024
    risk 0.33cvss 6.1epss 0.01

    The Yoast SEO plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via URLs in all versions up to, and including, 22.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts…

  • CVE-2024-3547MedMay 14, 2024
    risk 0.33cvss 6.1epss 0.00

    The Unlimited Elements For Elementor (Free Widgets, Addons, Templates) plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'google_connect_error' parameter in all versions up to, and including, 1.5.102 due to insufficient input sanitization and output…

  • CVE-2024-30268MedMay 14, 2024
    risk 0.33cvss 6.1epss 0.01

    Cacti provides an operational monitoring and fault management framework. A reflected cross-site scripting vulnerability on the 1.3.x DEV branch allows attackers to obtain cookies of administrator and other users and fake their login using obtained cookies. This issue is fixed in…

  • CVE-2024-34078MedMay 6, 2024
    risk 0.33cvss 6.1epss 0.01

    html-sanitizer is an allowlist-based HTML cleaner. If using `keep_typographic_whitespace=False` (which is the default), the sanitizer normalizes unicode to the NFKC form at the end. Some unicode characters normalize to chevrons; this allows specially crafted HTML to escape…

  • CVE-2024-34500MedMay 5, 2024
    risk 0.33cvss 6.1epss 0.00

    An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. XSS can occur through an interface message. Error messages (in the $err var) are not escaped before being passed to Html::rawElement() in the…

  • CVE-2024-34467MedMay 4, 2024
    risk 0.33cvss 6.1epss 0.00

    ThinkPHP 8.0.3 allows remote attackers to exploit XSS due to inadequate filtering of function argument values in think_exception.tpl.

  • CVE-2024-34067MedMay 3, 2024
    risk 0.33cvss 6.1epss 0.00

    Pterodactyl is a free, open-source game server management panel built with PHP, React, and Go. Importing a malicious egg or gaining access to wings instance could lead to cross site scripting (XSS) on the panel, which could be used to gain an administrator account on the panel.…

  • CVE-2024-32890MedMay 1, 2024
    risk 0.33cvss 6.1epss 0.01

    librespeed/speedtest is an open source, self-hosted speed test for HTML5. In affected versions missing neutralization of the ISP information in a speedtest result leads to stored Cross-site scripting in the JSON API. The `processedString` field in the `ispinfo` parameter is…

  • CVE-2024-28979MedMay 1, 2024
    risk 0.33cvss 5.1epss 0.00

    Dell OpenManage Enterprise, versions 4.1.0 and older, contains an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Script…

  • CVE-2024-31574MedApr 25, 2024
    risk 0.33cvss 5.0epss 0.00

    Cross Site Scripting vulnerability in TWCMS v.2.6 allows a local attacker to execute arbitrary code via a crafted script

  • CVE-2024-32875MedApr 23, 2024
    risk 0.33cvss 6.1epss 0.01

    Hugo is a static site generator. Starting in version 0.123.0 and prior to version 0.125.3, title arguments in Markdown for links and images not escaped in internal render hooks. Hugo users who are impacted are those who have these hooks enabled and do not trust their Markdown…

  • CVE-2024-29183MedApr 19, 2024
    risk 0.33cvss 6.1epss 0.00

    OpenRASP is a RASP solution that directly integrates its protection engine into the application server by instrumentation. There exists a reflected XSS in the /login page due to a reflection of the redirect parameter. This allows an attacker to execute arbitrary javascript with…

  • CVE-2024-29029MedApr 19, 2024
    risk 0.33cvss 6.1epss 0.01

    memos is a privacy-first, lightweight note-taking service. In memos 0.13.2, an SSRF vulnerability exists at the /o/get/image that allows unauthenticated users to enumerate the internal network and retrieve images. The response from the image request is then copied into the…

  • CVE-2024-3731MedApr 19, 2024
    risk 0.33cvss 6.1epss 0.00

    The Customer Reviews for WooCommerce plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 's' parameter in all versions up to, and including, 5.47.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated…

  • CVE-2024-27306MedApr 18, 2024
    risk 0.33cvss 6.1epss 0.01

    aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. A XSS vulnerability exists on index pages for static file handling. This vulnerability is fixed in 3.9.4. We have always recommended using a reverse proxy server (e.g. nginx) for serving static…

  • CVE-2024-2833MedApr 18, 2024
    risk 0.33cvss 6.1epss 0.00

    The Jobs for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘job-search’ parameter in all versions up to, and including, 2.7.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated…

  • CVE-2024-32472MedApr 17, 2024
    risk 0.33cvss 6.1epss 0.01

    excalidraw is an open source virtual hand-drawn style whiteboard. A stored XSS vulnerability in Excalidraw's web embeddable component. This allows arbitrary JavaScript to be run in the context of the domain where the editor is hosted. There were two vectors. One rendering…

  • CVE-2024-32489MedApr 15, 2024
    risk 0.33cvss 6.1epss 0.01

    TCPDF before 6.7.4 mishandles calls that use HTML syntax.