VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 595 of 2,429
  • CVE-2026-92212MedSep 25, 2026
    risk 0.40cvss 6.1epss 0.00

    The JetFormBuilder — Dynamic Blocks Form Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via 'jfb_xss' (URL Query Variable) Parameter via Calculated Field in all versions up to, and including, 3.6.5.3 due to insufficient input sanitization and…

  • CVE-2026-78393MedSep 25, 2026
    risk 0.40cvss 6.1epss 0.00

    The Link Library WordPress plugin before 7.9.6 does not properly escape some parameters before outputting them in the addresses of links it generates on its front-end directory pages, leading to Reflected Cross-Site Scripting which could be used against any visitor, including…

  • CVE-2026-61823HigSep 24, 2026
    risk 0.40cvss 7.3epss 0.00

    code16 Sharp is a Laravel-based framework for building content-management and administrative interfaces. Versions before 9.22.5 contain a stored cross-site scripting vulnerability in the rich-text editor because the HTML sanitizer permits the `srcdoc` attribute on iframe…

  • CVE-2026-93769HigSep 23, 2026
    risk 0.40cvss —epss 0.00

    HumHub 1.18.5 is affected by a stored cross-site scripting (XSS) vulnerability that allows any user holding the delegated, non-system-administrator Manage Users permission (admin_manage_users) to inject persistent HTML/JavaScript into a Profile Field Category title.

  • CVE-2026-91999MedSep 23, 2026
    risk 0.40cvss 6.1epss 0.01

    Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.

  • CVE-2026-91928MedSep 23, 2026
    risk 0.40cvss 6.1epss 0.01

    Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.

  • CVE-2026-91852MedSep 23, 2026
    risk 0.40cvss 6.1epss 0.01

    Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.

  • CVE-2026-73192MedSep 23, 2026
    risk 0.40cvss 6.1epss 0.01

    An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability when using the XSSAPI.getValidHref() in Apache Sling XSS version 2.4.10 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack in…

  • CVE-2026-88020MedSep 22, 2026
    risk 0.40cvss 6.1epss 0.00

    Autonomy Logic OpenPLC 3 is susceptible to an improper neutralization of input during web page generation vulnerability when the web interface attempts to route the program based on a query string parameter with no encoding.

  • CVE-2026-48361MedSep 22, 2026
    risk 0.40cvss 6.1epss 0.00

    Adobe Connect is affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim's browser when they browse to the page containing the…

  • CVE-2026-79311MedSep 22, 2026
    risk 0.40cvss 6.1epss 0.00

    webpy web.py 0.76 is vulnerable to Cross Site Scripting (XSS) via render_jinja.__init__().

  • CVE-2026-89412HigSep 22, 2026
    risk 0.40cvss 7.2epss 0.01

    The TranslatePress – Translate Multilingual sites with AI Translation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Translation Memory Suggestion Panel (v-html on suggestion.original) in all versions up to, and including, 3.3.5 due to insufficient input…

  • CVE-2026-93655MedSep 22, 2026
    risk 0.40cvss 6.1epss 0.00

    The Booking Calendar plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wpbc_auto_fill' parameter in all versions up to, and including, 11.8.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated…

  • CVE-2026-88745MedSep 21, 2026
    risk 0.40cvss 6.1epss 0.00

    EMLOG-Pro 2.6.29 contains a XSS vulnerability that enables attackers to upload a malicious shell.

  • CVE-2026-79320MedSep 21, 2026
    risk 0.40cvss 6.1epss 0.00

    Stencil core 4.43.5 contains a DOM-based cross-site scripting (XSS) vulnerability in the component runtime. When a downstream application enables the experimental slot fixes option and uses scoped components, assigning a string to the textContent property of such a component's…

  • CVE-2026-36468MedSep 21, 2026
    risk 0.40cvss 6.1epss 0.00

    Cross-site Scripting (XSS) in index.php in CuteNews v.2.1.2 allows remote unauthenticated attackers to supply an arbitrarily named URL parameter key, with part of its name containing any URL-encoded common XSS payload (such as ">).

  • CVE-2026-15463MedSep 19, 2026
    risk 0.40cvss 6.1epss 0.00

    The SSL Zen — SSL Certificate Installer & HTTPS Redirects plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'host' parameter in all versions up to, and including, 4.7.42 due to insufficient input sanitization and output escaping. This makes it…

  • CVE-2026-11608MedSep 19, 2026
    risk 0.40cvss 6.1epss 0.00

    The WP Customer Reviews plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wpcr3_fname' parameter in all versions up to, and including, 3.7.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated…

  • CVE-2026-92967MedSep 19, 2026
    risk 0.40cvss 6.1epss 0.00

    The Pochipp plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'keyword' parameter in versions up to, and including, 1.20.2. This is due to insufficient output escaping , which reads $_GET['keyword'], applies only sanitize_text_field() (which strips…

  • CVE-2026-89081MedSep 19, 2026
    risk 0.40cvss 6.1epss 0.00

    The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'search' parameter in all versions up to, and including, 4.0.8 due to insufficient input sanitization and output escaping. This makes it possible…