VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1654 of 2,429
  • CVE-2018-12581MedJun 21, 2018
    risk 0.33cvss 6.1epss 0.02

    An issue was discovered in js/designer/move.js in phpMyAdmin before 4.8.2. A Cross-Site Scripting vulnerability has been found where an attacker can use a crafted database name to trigger an XSS attack when that database is referenced from the Designer feature.

  • CVE-2018-12104MedJun 17, 2018
    risk 0.33cvss 6.1epss 0.01

    Cross-site scripting (XSS) vulnerability in Airbnb Knowledge Repo 0.7.4 allows remote attackers to inject arbitrary web scripts or HTML via the post comments functionality, as demonstrated by the post/posts/new_report.kp URI.

  • CVE-2018-11647MedJun 17, 2018
    risk 0.33cvss 6.1epss 0.01

    index.js in oauth2orize-fprm before 0.2.1 has XSS via a crafted URL.

  • CVE-2018-12432MedJun 14, 2018
    risk 0.33cvss 6.1epss 0.01

    JavaMelody through 1.60.0 has XSS via the counter parameter in a clear_counter action to the /monitoring URI.

  • CVE-2018-11688MedJun 13, 2018
    risk 0.33cvss 6.1epss 0.02

    Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the…

  • CVE-2018-3726MedJun 7, 2018
    risk 0.33cvss 6.1epss 0.01

    crud-file-server node module before 0.8.0 suffers from a Cross-Site Scripting vulnerability to a lack of validation of file names.

  • CVE-2017-16016MedJun 4, 2018
    risk 0.33cvss 6.1epss 0.01

    Sanitize-html is a library for scrubbing html input of malicious values. Versions 1.11.1 and below are vulnerable to cross site scripting (XSS) in certain scenarios: If allowed at least one nonTextTags, the result is a potential XSS vulnerability.

  • CVE-2017-16015MedJun 4, 2018
    risk 0.33cvss 6.1epss 0.01

    Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting

  • CVE-2016-10531MedMay 31, 2018
    risk 0.33cvss 6.1epss 0.01

    marked is an application that is meant to parse and compile markdown. Due to the way that marked 0.3.5 and earlier parses input, specifically HTML entities, it's possible to bypass marked's content injection protection (`sanitize: true`) to inject a `javascript:` URL. This flaw…

  • CVE-2014-10065MedMay 31, 2018
    risk 0.33cvss 6.1epss 0.01

    Certain input when passed into remarkable before 1.4.1 will bypass the bad protocol check that disallows the javascript: scheme allowing for javascript: url's to be injected into the rendered content.

  • CVE-2018-11627MedMay 31, 2018
    risk 0.33cvss 6.1epss 0.02

    Sinatra before 2.0.2 has XSS via the 400 Bad Request page that occurs upon a params parser exception.

  • CVE-2018-10428MedMay 23, 2018
    risk 0.33cvss 6.1epss 0.02

    ILIAS before 5.1.26, 5.2.x before 5.2.15, and 5.3.x before 5.3.4, due to inconsistencies in parameter handling, is vulnerable to various instances of reflected cross-site-scripting.

  • CVE-2018-11093MedMay 22, 2018
    risk 0.33cvss 6.1epss 0.01

    Cross-site scripting (XSS) vulnerability in the Link package for CKEditor 5 before 10.0.1 allows remote attackers to inject arbitrary web script through a crafted href attribute of a link (A) element.

  • CVE-2018-11366MedMay 22, 2018
    risk 0.33cvss 6.1epss 0.02

    init.php in the Loginizer plugin 1.3.8 through 1.3.9 for WordPress has Unauthenticated Stored Cross-Site Scripting (XSS) because logging is mishandled. This is fixed in 1.4.0.

  • CVE-2018-11105MedMay 15, 2018
    risk 0.33cvss 6.1epss 0.01

    There is stored cross site scripting in the wp-live-chat-support plugin before 8.0.08 for WordPress via the "name" (aka wplc_name) and "email" (aka wplc_email) input fields to wp-json/wp_live_chat_support/v1/start_chat whenever a malicious attacker would initiate a new chat with…

  • CVE-2018-9861MedApr 19, 2018
    risk 0.33cvss 6.1epss 0.02

    Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script…

  • CVE-2018-8071MedApr 18, 2018
    risk 0.33cvss 6.1epss 0.01

    Mautic before v2.13.0 has stored XSS via a theme config file.

  • CVE-2018-10102MedApr 16, 2018
    risk 0.33cvss 6.1epss 0.04

    Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.

  • CVE-2015-4557MedApr 12, 2018
    risk 0.33cvss 6.1epss 0.02

    Cross-site scripting (XSS) vulnerability in the new_Twitter_sign_button function in nextend-Twitter-connect.php in the Nextend Twitter Connect plugin before 1.5.2 for WordPress allows remote attackers to inject arbitrary web script or HTML via the redirect_to parameter. NOTE:…

  • CVE-2018-3741MedMar 30, 2018
    risk 0.33cvss 6.1epss 0.01

    There is a possible XSS vulnerability in all rails-html-sanitizer gem versions below 1.0.4 for Ruby. The gem allows non-whitelisted attributes to be present in sanitized output when input with specially-crafted HTML fragments, and these attributes can lead to an XSS attack on…