VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1636 of 2,429
  • CVE-2021-45229MedFeb 25, 2022
    risk 0.33cvss 6.1epss 0.03

    It was discovered that the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument. This issue affects Apache Airflow versions 2.2.3 and below.

  • CVE-2022-0690MedFeb 19, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.

  • CVE-2022-0678MedFeb 19, 2022
    risk 0.33cvss 6.1epss 0.02

    Cross-site Scripting (XSS) - Reflected in Packagist microweber/microweber prior to 1.2.11.

  • CVE-2022-23638MedFeb 14, 2022
    risk 0.33cvss 6.2epss 0.01

    svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.

  • CVE-2022-0576MedFeb 14, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Generic in Packagist librenms/librenms prior to 22.1.0.

  • CVE-2020-13669MedFeb 11, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

  • CVE-2020-13668MedFeb 11, 2022
    risk 0.33cvss 6.1epss 0.01

    Access Bypass vulnerability in Drupal Core allows for an attacker to leverage the way that HTML is rendered for affected forms in order to exploit the vulnerability. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions…

  • CVE-2022-0149MedFeb 7, 2022
    risk 0.33cvss 6.1epss 0.02

    The WooCommerce Stored Exporter WordPress plugin before 2.7.1 was affected by a Reflected Cross-Site Scripting (XSS) vulnerability in the woo_ce admin page.

  • CVE-2021-25077MedFeb 7, 2022
    risk 0.33cvss 6.1epss 0.01

    The Store Toolkit for WooCommerce WordPress plugin before 2.3.2 does not sanitise and escape the tab parameter before outputting it back in an admin page in an error message, leading to a Reflected Cross-Site Scripting

  • CVE-2022-0501MedFeb 5, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Reflected in Packagist ptrofimov/beanstalk_console prior to 1.7.12.

  • CVE-2022-22818MedFeb 3, 2022
    risk 0.33cvss 6.1epss 0.03

    The {% debug %} template tag in Django 2.2 before 2.2.27, 3.2 before 3.2.12, and 4.0 before 4.0.2 does not properly encode the current context. This may lead to XSS.

  • CVE-2021-24975MedFeb 1, 2022
    risk 0.33cvss 6.1epss 0.01

    The NextScripts: Social Networks Auto-Poster WordPress plugin before 4.3.24 does not sanitise and escape logged requests before outputting them in the related admin dashboard, leading to an Unauthenticated Stored Cross-Site Scripting issue

  • CVE-2022-23598MedJan 28, 2022
    risk 0.33cvss 6.1epss 0.01

    laminas-form is a package for validating and displaying simple and complex forms. When rendering validation error messages via the `formElementErrors()` view helper shipped with laminas-form, many messages will contain the submitted value. However, in laminas-form prior to…

  • CVE-2022-0352MedJan 28, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Reflected in Pypi calibreweb prior to 0.6.16.

  • CVE-2021-25083MedJan 24, 2022
    risk 0.33cvss 6.1epss 0.01

    The Registrations for the Events Calendar WordPress plugin before 2.7.10 does not escape the qtype parameter before outputting it back in an attribute in the settings page, leading to a Reflected Cross-Site Scripting

  • CVE-2021-25078MedJan 24, 2022
    risk 0.33cvss 6.1epss 0.02

    The Affiliates Manager WordPress plugin before 2.9.0 does not validate, sanitise and escape the IP address of requests logged by the click tracking feature, allowing unauthenticated attackers to perform Cross-Site Scripting attacks against admin viewing the tracked requests.

  • CVE-2021-25062MedJan 24, 2022
    risk 0.33cvss 6.1epss 0.01

    The Orders Tracking for WooCommerce WordPress plugin before 1.1.10 does not sanitise and escape the file_url before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting

  • CVE-2021-25017MedJan 24, 2022
    risk 0.33cvss 6.1epss 0.01

    The Tutor LMS WordPress plugin before 1.9.12 does not escape the search parameter before outputting it back in an attribute in an admin page, leading to a Reflected Cross-Site Scripting

  • CVE-2021-25015MedJan 24, 2022
    risk 0.33cvss 6.1epss 0.01

    The myCred WordPress plugin before 2.4 does not sanitise and escape the search query before outputting it back in the history dashboard page, leading to a Reflected Cross-Site Scripting issue

  • CVE-2021-25008MedJan 24, 2022
    risk 0.33cvss 6.1epss 0.02

    The Code Snippets WordPress plugin before 2.14.3 does not escape the snippets-safe-mode parameter before outputting it back in attributes, leading to a Reflected Cross-Site Scripting issue