VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1635 of 2,429
  • CVE-2020-29653MedApr 13, 2022
    risk 0.33cvss 6.1epss 0.01

    Froxlor through 0.10.22 does not perform validation on user input passed in the customermail GET parameter. The value of this parameter is reflected in the login webpage, allowing the injection of arbitrary HTML tags.

  • CVE-2022-0471MedApr 11, 2022
    risk 0.33cvss 6.1epss 0.01

    The Favicon by RealFaviconGenerator WordPress plugin before 1.3.23 does not properly sanitise and escape the json_result_url parameter before outputting it back in the Favicon admin dashboard, leading to a Reflected Cross-Site Scripting issue

  • CVE-2022-28378MedApr 3, 2022
    risk 0.33cvss 6.1epss 0.01

    Craft CMS before 3.7.29 allows XSS.

  • CVE-2003-5003MedMar 28, 2022
    risk 0.33cvss 5.0epss 0.01

    A vulnerability was found in ISS BlackICE PC Protection. It has been rated as problematic. Affected by this issue is the Update Handler. The manipulation with an unknown input leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to…

  • CVE-2022-0951MedMar 15, 2022
    risk 0.33cvss 6.1epss 0.01

    File Upload Restriction Bypass leading to Stored XSS Vulnerability in GitHub repository star7th/showdoc prior to 2.10.4.

  • CVE-2022-0399MedMar 14, 2022
    risk 0.33cvss 6.1epss 0.01

    The Advanced Product Labels for WooCommerce WordPress plugin before 1.2.3.7 does not sanitise and escape the tax_color_set_type parameter before outputting it back in the berocket_apl_color_listener AJAX action's response, leading to a Reflected Cross-Site Scripting

  • CVE-2022-0929MedMar 12, 2022
    risk 0.33cvss 6.1epss 0.01

    XSS on dynamic_text module in GitHub repository microweber/microweber prior to 1.2.11.

  • CVE-2022-26533MedMar 12, 2022
    risk 0.33cvss 6.1epss 0.01

    Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist.

  • CVE-2021-44667MedMar 11, 2022
    risk 0.33cvss 6.1epss 0.01

    A Cross Site Scripting (XSS) vulnerability exists in Nacos 2.0.3 in auth/users via the (1) pageSize and (2) pageNo parameters.

  • CVE-2021-32478MedMar 11, 2022
    risk 0.33cvss 6.1epss 0.01

    The redirect URI in the LTI authorization endpoint required extra sanitizing to prevent reflected XSS and open redirect risks. Moodle versions 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8 and earlier unsupported versions are affected.

  • CVE-2021-32009MedMar 11, 2022
    risk 0.33cvss 5.0epss 0.01

    Cross-site Scripting (XSS) vulnerability in firmware section of Secomea GateManager allows logged in user to inject javascript in browser session. This issue affects: Secomea GateManager Version 9.6.621421014 and all prior versions.

  • CVE-2021-44585MedMar 10, 2022
    risk 0.33cvss 6.1epss 0.01

    A Cross Site Scripting (XSS) vulnerabilitiy exits in jeecg-boot 3.0 in /jeecg-boot/jmreport/view with a mouseover event.

  • CVE-2022-24746MedMar 9, 2022
    risk 0.33cvss 6.1epss 0.01

    Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions it is possible to inject code via the voucher code form. This issue has been patched in version 6.4.8.1. There are no known workarounds for this issue.

  • CVE-2022-0533MedMar 7, 2022
    risk 0.33cvss 6.1epss 0.02

    The Ditty (formerly Ditty News Ticker) WordPress plugin before 3.0.15 is affected by a Reflected Cross-Site Scripting (XSS) vulnerability.

  • CVE-2022-0422MedMar 7, 2022
    risk 0.33cvss 6.1epss 0.08

    The White Label CMS WordPress plugin before 2.2.9 does not sanitise and validate the wlcms[_login_custom_js] parameter before outputting it back in the response while previewing, leading to a Reflected Cross-Site Scripting issue

  • CVE-2022-0832MedMar 4, 2022
    risk 0.33cvss 5.4epss 0.67

    Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.3.3.

  • CVE-2021-38264MedMar 3, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site scripting (XSS) vulnerability in the Frontend Taglib module in Liferay Portal 7.4.0 and 7.4.1 allows remote attackers to inject arbitrary web script or HTML into the management toolbar search via the `keywords` parameter. This issue is caused by an incomplete fix in…

  • CVE-2021-38263MedMar 3, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site scripting (XSS) vulnerability in the Server module's script console in Liferay Portal 7.3.2 and earlier, and Liferay DXP 7.0 before fix pack 101, 7.1 before fix pack 20 and 7.2 before fix pack 10 allows remote attackers to inject arbitrary web script or HTML via the…

  • CVE-2022-24717MedMar 1, 2022
    risk 0.33cvss 6.1epss 0.01

    ssr-pages is an HTML page builder for the purpose of server-side rendering (SSR). In versions prior to 0.1.5, a cross site scripting (XSS) issue can occur when providing untrusted input to the `redirect.link` property as an argument to the `build(MessagePageOptions)` function.…

  • CVE-2022-0776MedMar 1, 2022
    risk 0.33cvss 6.1epss 0.04

    Cross-site Scripting (XSS) - DOM in GitHub repository hakimel/reveal.js prior to 4.3.0.