VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1631 of 2,429
  • CVE-2022-43497MedDec 5, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.

  • CVE-2022-3561MedNov 20, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Generic in GitHub repository librenms/librenms prior to 22.10.0.

  • CVE-2022-3516MedNov 20, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.10.0.

  • CVE-2022-42118MedNov 15, 2022
    risk 0.33cvss 6.1epss 0.01

    A Cross-site scripting (XSS) vulnerability in the Portal Search module in Liferay Portal 7.1.0 through 7.4.2, and Liferay DXP 7.1 before fix pack 27, 7.2 before fix pack 15, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML via the…

  • CVE-2022-42110MedNov 15, 2022
    risk 0.33cvss 6.1epss 0.01

    A Cross-site scripting (XSS) vulnerability in the Announcements module in Liferay Portal 7.1.0 through 7.4.2, and Liferay DXP 7.1 before fix pack 27, 7.2 before fix pack 17, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML.

  • CVE-2022-43968MedNov 14, 2022
    risk 0.33cvss 6.1epss 0.01

    Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Reflected XSS in the dashboard icons due to un-sanitized output. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

  • CVE-2022-43967MedNov 14, 2022
    risk 0.33cvss 6.1epss 0.01

    Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Reflected XSS in the multilingual report due to un-sanitized output. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

  • CVE-2022-43694MedNov 14, 2022
    risk 0.33cvss 6.1epss 0.01

    Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Reflected XSS in the image manipulation library due to un-sanitized output.

  • CVE-2022-43692MedNov 14, 2022
    risk 0.33cvss 6.1epss 0.01

    Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 is vulnerable to Reflected XSS - user can cause an administrator to trigger reflected XSS with a url if the targeted administrator is using an old browser that lacks XSS protection. Remediate by updating…

  • CVE-2022-3869MedNov 5, 2022
    risk 0.33cvss 6.1epss 0.02

    Code Injection in GitHub repository froxlor/froxlor prior to 0.10.38.2.

  • CVE-2022-43982MedNov 2, 2022
    risk 0.33cvss 6.1epss 0.02

    In Apache Airflow versions prior to 2.4.2, the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument.

  • CVE-2022-40184MedOct 27, 2022
    risk 0.33cvss 5.1epss 0.00

    Incomplete filtering of JavaScript code in different configuration fields of the web based interface of the VIDEOJET multi 4000 allows an attacker with administrative credentials to store JavaScript code which will be executed for all administrators accessing the same…

  • CVE-2022-42466MedOct 19, 2022
    risk 0.33cvss 6.1epss 0.01

    Prior to 2.0.0-M9, it was possible for an end-user to set the value of an editable string property of a domain object to a value that would be rendered unchanged when the value was saved. In particular, the end-user could enter javascript or similar and this would be executed.…

  • CVE-2022-42117MedOct 18, 2022
    risk 0.33cvss 6.1epss 0.01

    A Cross-site scripting (XSS) vulnerability in the Frontend Taglib module in Liferay Portal 7.3.2 through 7.4.3.16, and Liferay DXP 7.3 before update 6, and 7.4 before update 17 allows remote attackers to inject arbitrary web script or HTML.

  • CVE-2022-42116MedOct 18, 2022
    risk 0.33cvss 6.1epss 0.01

    A Cross-site scripting (XSS) vulnerability in the Frontend Editor module's integration with CKEditor in Liferay Portal 7.3.2 through 7.4.3.14, and Liferay DXP 7.3 before update 6, and 7.4 before update 15 allows remote attackers to inject arbitrary web script or HTML via the (1)…

  • CVE-2022-42113MedOct 18, 2022
    risk 0.33cvss 6.1epss 0.01

    A Cross-site scripting (XSS) vulnerability in Document Library module in Liferay Portal 7.4.3.30 through 7.4.3.36, and Liferay DXP 7.4 update 30 through update 36 allows remote attackers to inject arbitrary web script or HTML via the `redirect` parameter.

  • CVE-2022-40931MedSep 29, 2022
    risk 0.33cvss 6.1epss 0.01

    dutchcoders Transfer.sh 1.4.0 is vulnerable to Cross Site Scripting (XSS).

  • CVE-2022-39239MedSep 23, 2022
    risk 0.33cvss 6.1epss 0.00

    netlify-ipx is an on-Demand image optimization for Netlify using ipx. In versions prior to 1.2.3, an attacker can bypass the source image domain allowlist by sending specially crafted headers, causing the handler to load and return arbitrary images. Because the response is…

  • CVE-2022-23458MedSep 22, 2022
    risk 0.33cvss 6.1epss 0.01

    Toast UI Grid is a component to display and edit data. Versions prior to 4.21.3 are vulnerable to cross-site scripting attacks when pasting specially crafted content into editable cells. This issue was fixed in version 4.21.3. There are no known workarounds.

  • CVE-2022-28980MedSep 22, 2022
    risk 0.33cvss 6.1epss 0.00

    Multiple cross-site scripting (XSS) vulnerabilities in Liferay Portal v7.4.3.4 and Liferay DXP v7.4 GA allows attackers to execute arbitrary web scripts or HTML via parameters with the filter_ prefix.