VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1630 of 2,429
  • CVE-2021-32855MedFeb 21, 2023
    risk 0.33cvss 6.1epss 0.01

    Vditor is a browser-side Markdown editor. Versions prior to 3.8.7 are vulnerable to copy-paste cross-site scripting (XSS). For this particular type of XSS, the victim needs to be fooled into copying a malicious payload into the text editor. Version 3.8.7 contains a patch for…

  • CVE-2021-32851MedFeb 20, 2023
    risk 0.33cvss 6.1epss 0.01

    Mind-elixir is a free, open source mind map core. Prior to version 0.18.1, mind-elixir is prone to cross-site scripting when handling untrusted menus. This issue is patched in version 0.18.1

  • CVE-2021-32850MedFeb 20, 2023
    risk 0.33cvss 6.1epss 0.01

    jQuery MiniColors is a color picker built on jQuery. Prior to version 2.3.6, jQuery MiniColors is prone to cross-site scripting when handling untrusted color names. This issue is patched in version 2.3.6.

  • CVE-2021-23980MedFeb 16, 2023
    risk 0.33cvss 6.1epss 0.00

    A mutation XSS affects users calling bleach.clean with all of: svg or math in the allowed tags p or br in allowed tags style, title, noscript, script, textarea, noframes, iframe, or xmp in allowed tags the keyword argument strip_comments=False Note: none of the above tags are in…

  • CVE-2022-4830MedFeb 13, 2023
    risk 0.33cvss 5.4epss 0.65

    The Paid Memberships Pro WordPress plugin before 2.9.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be…

  • CVE-2022-45598MedJan 31, 2023
    risk 0.33cvss 6.1epss 0.00

    Cross Site Scripting vulnerability in Joplin Desktop App before v2.9.17 allows attacker to execute arbitrary code via improper santization.

  • CVE-2023-0566MedJan 29, 2023
    risk 0.33cvss 6.2epss 0.00

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in froxlor/froxlor prior to 2.0.10.

  • CVE-2023-23627MedJan 28, 2023
    risk 0.33cvss 6.1epss 0.01

    Sanitize is an allowlist-based HTML and CSS sanitizer. Versions 5.0.0 and later, prior to 6.0.1, are vulnerable to Cross-site Scripting. When Sanitize is configured with a custom allowlist that allows `noscript` elements, attackers are able to include arbitrary HTML, resulting…

  • CVE-2023-0410MedJan 20, 2023
    risk 0.33cvss 6.1epss 0.00

    Cross-site Scripting (XSS) - Generic in GitHub repository builderio/qwik prior to 0.1.0-beta5.

  • CVE-2023-0314MedJan 15, 2023
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.1.10.

  • CVE-2023-0312MedJan 15, 2023
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Stored in GitHub repository thorsten/phpmyfaq prior to 3.1.10.

  • CVE-2021-46871MedJan 10, 2023
    risk 0.33cvss 6.1epss 0.00

    tag.ex in Phoenix Phoenix.HTML (aka phoenix_html) before 3.0.4 allows XSS in HEEx class attributes.

  • CVE-2022-46180MedJan 4, 2023
    risk 0.33cvss 5.0epss 0.00

    Discourse Mermaid (discourse-mermaid-theme-component) allows users of Discourse, open-source forum software, to create graphs using the Mermaid syntax. Users of discourse-mermaid-theme-component version 1.0.0 who can create posts are able to inject arbitrary HTML on that post.…

  • CVE-2022-46181MedDec 29, 2022
    risk 0.33cvss 6.1epss 0.01

    Gotify server is a simple server for sending and receiving messages in real-time per WebSocket. Versions prior to 2.2.2 contain an XSS vulnerability that allows authenticated users to upload .html files. An attacker could execute client side scripts **if** another user opened a…

  • CVE-2021-30134MedDec 26, 2022
    risk 0.33cvss 6.1epss 0.01

    php-mod/curl (a wrapper of the PHP cURL extension) before 2.3.2 allows XSS via the post_file_path_upload.php key parameter and the POST data to post_multidimensional.php.

  • CVE-2022-4647MedDec 22, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Stored in GitHub repository microweber/microweber prior to 1.3.2.

  • CVE-2022-4617MedDec 21, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.3.2.

  • CVE-2022-23474MedDec 15, 2022
    risk 0.33cvss 6.1epss 0.01

    Editor.js is a block-style editor with clean JSON output. Versions prior to 2.26.0 are vulnerable to Code Injection via pasted input. The processHTML method passes pasted input into wrapper’s innerHTML. This issue is patched in version 2.26.0.

  • CVE-2022-23515MedDec 14, 2022
    risk 0.33cvss 6.1epss 0.01

    Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.

  • CVE-2022-43500MedDec 5, 2022
    risk 0.33cvss 6.1epss 0.01

    Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.