VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 899 of 2,429
  • CVE-2014-4592MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.04

    Cross-site scripting (XSS) vulnerability in rss.class/scripts/magpie_debug.php in the WP-Planet plugin 0.1 and earlier for WordPress allows remote attackers to inject arbitrary web script or HTML via the url parameter.

  • CVE-2014-4519MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting (XSS) vulnerability in the Conversador plugin 2.61 and earlier for WordPress allows remote attackers to inject arbitrary web script or HTML via the 'page' parameter.

  • CVE-2013-4693MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.01

    WordPress Xorbin Digital Flash Clock 1.0 has XSS

  • CVE-2013-4691MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.01

    Sencha Labs Connect has XSS with connect.methodOverride()

  • CVE-2014-4559MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.01

    Multiple cross-site scripting (XSS) vulnerabilities in test-plugin.php in the Swipe Checkout for WP e-Commerce plugin 3.1.0 and earlier for WordPress allow remote attackers to inject arbitrary web script or HTML via the (1) api_key, (2) payment_page_url, (3) merchant_id, (4)…

  • CVE-2014-4525MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting (XSS) vulnerability in magpie/scripts/magpie_slashbox.php in the Ebay Feeds for WordPress plugin 1.1 and earlier for WordPress allows remote attackers to inject arbitrary web script or HTML via the rss_url parameter.

  • CVE-2014-4523MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting (XSS) vulnerability in the Easy Career Openings plugin 0.4 and earlier for WordPress allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

  • CVE-2019-20042MedDec 27, 2019
    risk 0.40cvss 6.1epss 0.03

    In wp-includes/formatting.php in WordPress 3.7 to 5.3.0, the function wp_targeted_link_rel() can be used in a particular way to result in a stored cross-site scripting (XSS) vulnerability. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions…

  • CVE-2019-6033MedDec 26, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in a-blog cms versions prior to Ver.2.10.23 (Ver.2.10.x), Ver.2.9.26 (Ver.2.9.x), and Ver.2.8.64 (Ver.2.8.x) allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2019-6031MedDec 26, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in KINZA for Windows version 5.9.2 and earlier and for Mac version 5.0.0 and earlier allows remote attackers to inject arbitrary web script or HTML via RSS reader.

  • CVE-2019-6029MedDec 26, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in Custom Body Class 0.6.0 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2019-6018MedDec 26, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in NetCommons 3.2.2 and earlier (NetCommons3.x) allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2019-6016MedDec 26, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in REMISE Payment Module (2.11, 2.12 and 2.13) version 3.0.12 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2019-6011MedDec 26, 2019
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in wpDataTables Lite Version 2.0.11 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2019-19540MedDec 26, 2019
    risk 0.40cvss 6.1epss 0.01

    The ListingPro theme before v2.0.14.2 for WordPress has Reflected XSS via the What field on the homepage.

  • CVE-2019-18249MedDec 24, 2019
    risk 0.40cvss 6.1epss 0.01

    Reliable Controls MACH-ProWebCom/Sys, all versions prior to 2.15 (Firmware versions prior to 8.26.4), may allow attacker to execute commands on behalf of the user when an authenticated user clicks on a malicious link.

  • CVE-2019-4744MedDec 20, 2019
    risk 0.40cvss 6.1epss 0.01

    IBM Financial Transaction Manager 3.0 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM…

  • CVE-2019-19916MedDec 20, 2019
    risk 0.40cvss 6.1epss 0.02

    In Midori Browser 0.5.11 (on Windows 10), Content Security Policy (CSP) is not applied correctly to all parts of multipart content sent with the multipart/x-mixed-replace MIME type. This could result in script running where CSP should have blocked it, allowing for cross-site…

  • CVE-2019-19692MedDec 20, 2019
    risk 0.40cvss 6.1epss 0.01

    Trend Micro Apex One (2019) is affected by a cross-site scripting (XSS) vulnerability on the product console. Note that the Japanese version of the product is NOT affected.

  • CVE-2016-1000229MedDec 20, 2019
    risk 0.40cvss 6.1epss 0.04

    swagger-ui has XSS in key names