VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 825 of 2,429
  • CVE-2021-38327MedSep 10, 2021
    risk 0.40cvss 6.1epss 0.01

    The YouTube Video Inserter WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to a reflected $_SERVER["PHP_SELF"] value in the ~/adminUI/settings.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.2.1.0.

  • CVE-2021-38326MedSep 10, 2021
    risk 0.40cvss 6.1epss 0.01

    The Post Title Counter WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the notice parameter found in the ~/post-title-counter.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.1.

  • CVE-2021-35976MedSep 10, 2021
    risk 0.40cvss 6.1epss 0.01

    The feature to preview a website in Plesk Obsidian 18.0.0 through 18.0.32 on Linux is vulnerable to reflected XSS via the /plesk-site-preview/ PATH, aka PFSI-62467. The attacker could execute JavaScript code in the victim's browser by using the link to preview sites hosted on…

  • CVE-2020-19295MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.04

    A reflected cross-site scripting (XSS) vulnerability in the /weibo/topic component of Jeesns 1.4.2 allows attackers to execute arbitrary web scripts or HTML.

  • CVE-2020-19283MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.03

    A reflected cross-site scripting (XSS) vulnerability in the /newVersion component of Jeesns 1.4.2 allows attackers to execute arbitrary web scripts or HTML.

  • CVE-2020-19282MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.03

    A reflected cross-site scripting (XSS) vulnerability in Jeesns 1.4.2 allows attackers to execute arbitrary web scripts or HTML via a crafted payload in the system error message's text field.

  • CVE-2021-38325MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The User Activation Email WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the uae-key parameter found in the ~/user-activation-email.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.3.0.

  • CVE-2021-38323MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The RentPress WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the selections parameter found in the ~/src/rentPress/AjaxRequests.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 6.6.4.

  • CVE-2021-38322MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The Twitter Friends Widget WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the pmc_TF_user and pmc_TF_password parameter found in the ~/twitter-friends-widget.php file which allows attackers to inject arbitrary web scripts, in versions up to and including…

  • CVE-2021-38321MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The Custom Menu Plugin WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the selected_menu parameter found in the ~/custom-menus.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.3.3.

  • CVE-2021-38320MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The simpleSAMLphp Authentication WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to a reflected $_SERVER["PHP_SELF"] value in the ~/simplesamlphp-authentication.php file which allows attackers to inject arbitrary web scripts, in versions up to and including…

  • CVE-2021-38319MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The More From Google WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to a reflected $_SERVER["PHP_SELF"] value in the ~/morefromgoogle.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 0.0.2.

  • CVE-2021-38318MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The 3D Cover Carousel WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the id parameter in the ~/cover-carousel.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.0.

  • CVE-2021-38317MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The Konnichiwa! Membership WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the plan_id parameter in the ~/views/subscriptions.html.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 0.8.3.

  • CVE-2021-38316MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    The WP Academic People List WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the category_name parameter in the ~/admin-panel.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 0.4.1.

  • CVE-2020-19266MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    A stored cross-site scripting (XSS) vulnerability in the index.php/Dswjcms/Site/articleList component of Dswjcms 1.6.4 allows attackers to execute arbitrary web scripts or HTML.

  • CVE-2020-19265MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.01

    A stored cross-site scripting (XSS) vulnerability in the index.php/Dswjcms/Basis/links component of Dswjcms 1.6.4 allows attackers to execute arbitrary web scripts or HTML.

  • CVE-2020-19515MedSep 9, 2021
    risk 0.40cvss 6.1epss 0.02

    qdPM V9.1 is vulnerable to Cross Site Scripting (XSS) via qdPM\install\modules\database_config.php.

  • CVE-2021-30689MedSep 8, 2021
    risk 0.40cvss 6.1epss 0.01

    A logic issue was addressed with improved state management. This issue is fixed in tvOS 14.6, iOS 14.6 and iPadOS 14.6, Safari 14.1.1, macOS Big Sur 11.4, watchOS 7.5. Processing maliciously crafted web content may lead to universal cross site scripting.

  • CVE-2021-1826MedSep 8, 2021
    risk 0.40cvss 6.1epss 0.01

    A logic issue was addressed with improved restrictions. This issue is fixed in macOS Big Sur 11.3, iOS 14.5 and iPadOS 14.5, watchOS 7.4, tvOS 14.5. Processing maliciously crafted web content may lead to universal cross site scripting.