VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 580 of 2,429
  • CVE-2025-34175MedSep 9, 2025
    risk 0.41cvss 6.1epss 0.21

    In pfSense CE /usr/local/www/suricata/suricata_filecheck.php, the value of the filehash parameter is directly displayed without sanitizing for HTML-related characters/strings. This can result in reflected cross-site scripting if the victim is authenticated.

  • CVE-2025-50927MedAug 8, 2025
    risk 0.41cvss 6.3epss 0.00

    A reflected cross-site scripting (XSS) vulnerability in the List All FTP User Function in EHCP v20.04.1.b allows authenticated attackers to execute arbitrary JavaScript via injecting a crafted payload into the ftpusername parameter.

  • CVE-2025-52358MedJul 29, 2025
    risk 0.41cvss 6.3epss 0.00

    A cross-site scripting vulnerability in Vivaldi United Group iCONTROL+ Server including Firmware version 4.7.8.0.eden Logic version 5.32 and below. This issue allows attackers to inject JavaScript payloads within the error or edit-menu-item parameters which are then executed in…

  • CVE-2025-7056MedJul 7, 2025
    risk 0.41cvss 6.3epss 0.00

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - UrlShortener Extension allows Stored XSS.This issue affects Mediawiki - UrlShortener Extension: from 1.42.X before 1.42.7, from 1.43.X…

  • CVE-2025-3745MedJun 30, 2025
    risk 0.41cvss 6.3epss 0.00

    The WP Lightbox 2 WordPress plugin before 3.0.6.8 does not correctly sanitize the value of the title attribute of links before using them, which may allow malicious users to conduct XSS attacks.

  • CVE-2025-47289MedJun 2, 2025
    risk 0.41cvss 6.3epss 0.00

    CE Phoenix is a free, open-source eCommerce platform. A stored cross-site scripting (XSS) vulnerability was discovered in CE Phoenix versions 1.0.9.9 through 1.1.0.2 where an attacker can inject malicious JavaScript into the testimonial description field. Once submitted, if the…

  • CVE-2024-56157MedMay 14, 2025
    risk 0.41cvss 6.3epss 0.00

    iTop is an web based IT Service Management tool. Prior to versions 3.1.3 and 3.2.1, by filling malicious code in a CSV content, a cross-site scripting attack can be performed when importing this content. The issue is fixed in versions 3.1.3 and 3.2.1. As a workaround, check CSV…

  • CVE-2024-30115MedApr 30, 2025
    risk 0.41cvss 6.3epss 0.00

    Insufficient sanitization policy in HCL Leap allows client-side script injection in the deployed application through the HTML widget.

  • CVE-2024-11922MedApr 28, 2025
    risk 0.41cvss 6.3epss 0.00

    Missing input validation in certain features of the Web Client of Fortra's GoAnywhere prior to version 7.8.0 allows an attacker with permission to trigger emails to insert arbitrary HTML or JavaScript into an email.

  • CVE-2024-30113MedApr 24, 2025
    risk 0.41cvss 6.3epss 0.00

    Insufficient sanitization policy in HCL Leap allows client-side script injection in the deployed application through the HTML widget.

  • CVE-2025-29513MedApr 18, 2025
    risk 0.41cvss 6.1epss 0.43

    Cross-Site Scripting (XSS) vulnerability in NodeBB v4.0.4 and before allows remote attackers to store arbitrary code in the admin API Access token generator.

  • CVE-2025-30292MedApr 8, 2025
    risk 0.41cvss 6.1epss 0.16

    ColdFusion versions 2023.12, 2021.18, 2025.0 and earlier are affected by a reflected Cross-Site Scripting (XSS) vulnerability. If an attacker is able to convince a victim to visit a URL referencing a vulnerable page, malicious JavaScript content may be executed within the…

  • CVE-2024-50053MedMar 21, 2025
    risk 0.41cvss 6.3epss 0.01

    Zohocorp ManageEngine ServiceDesk Plus versions below 14920 , ServiceDesk Plus MSP and SupportCentre Plus versions below 14910 are vulnerable to Stored XSS in the task feature.

  • CVE-2025-2031MedMar 6, 2025
    risk 0.41cvss 6.3epss 0.00

    A vulnerability classified as critical has been found in ChestnutCMS up to 1.5.2. This affects the function uploadFile of the file /dev-api/cms/file/upload. The manipulation of the argument file leads to unrestricted upload. It is possible to initiate the attack remotely. The…

  • CVE-2024-48589MedFeb 6, 2025
    risk 0.41cvss 6.3epss 0.01

    Cross Site Scripting vulnerability in Gilnei Moraes phpABook v.0.9 allows a remote attacker to execute arbitrary code via the rol parameter in index.php

  • CVE-2020-36085MedFeb 6, 2025
    risk 0.41cvss 6.3epss 0.00

    Stored Cross Site Scripting(XSS) vulnerability in Egavilan Media Resumes Management and Job Application Website 1.0 allows remote attackers to inject arbitrary code via First and Last Name in Apply For This Job Form.

  • CVE-2024-57237MedFeb 3, 2025
    risk 0.41cvss 6.3epss 0.00

    Prolink 4G LTE Mobile Wi-Fi DL-7203E V4.0.0B05 is vulnerable to Cross Site Scripting (XSS) in the /reqproc/proc_get endpoint. The vulnerability arises because the cmd parameter does not properly sanitize input and the response is served with a Content-Type of text/html. This…

  • CVE-2025-21393MedJan 14, 2025
    risk 0.41cvss 6.3epss 0.01

    Microsoft SharePoint Server Spoofing Vulnerability

  • CVE-2024-32770MedNov 22, 2024
    risk 0.41cvss 6.3epss 0.00

    A cross-site scripting (XSS) vulnerability has been reported to affect Photo Station. If exploited, the vulnerability could allow remote attackers who have gained user access to inject malicious code. We have already fixed the vulnerability in the following version: Photo…

  • CVE-2024-32769MedNov 22, 2024
    risk 0.41cvss 6.3epss 0.00

    A cross-site scripting (XSS) vulnerability has been reported to affect Photo Station. If exploited, the vulnerability could allow remote attackers who have gained user access to inject malicious code. We have already fixed the vulnerability in the following version: Photo…