VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 570 of 2,429
  • CVE-2022-3991MedNov 29, 2022
    risk 0.42cvss 6.4epss 0.01

    The Photospace Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its settings parameters saved via the update() function in versions up to, and including, 2.3.5 due to insufficient input sanitization and output escaping. This makes it possible for…

  • CVE-2022-4022MedNov 16, 2022
    risk 0.42cvss 6.4epss 0.00

    The SVG Support plugin for WordPress defaults to insecure settings in version 2.5 and 2.5.1. SVG files containing malicious javascript are not sanitized. While version 2.5 adds the ability to sanitize image as they are uploaded, the plugin defaults to disable sanitization and…

  • CVE-2022-42460MedNov 10, 2022
    risk 0.42cvss 6.5epss 0.00

    Broken Access Control vulnerability leading to Stored Cross-Site Scripting (XSS) in Traffic Manager plugin <= 1.4.5 on WordPress.

  • CVE-2022-44590MedNov 9, 2022
    risk 0.42cvss 6.4epss 0.01

    Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in James Lao's Simple Video Embedder plugin <= 2.2 on WordPress.

  • CVE-2022-41258MedNov 8, 2022
    risk 0.42cvss 6.5epss 0.00

    Due to insufficient input validation, SAP Financial Consolidation - version 1010, allows an authenticated attacker to inject malicious script when running a common query in the Web Administration Console. On successful exploitation, an attacker can view or modify information…

  • CVE-2022-43561MedNov 3, 2022
    risk 0.42cvss 6.4epss 0.01

    In Splunk Enterprise versions below 8.1.12, 8.2.9, and 9.0.2, a remote user that holds the “power” Splunk role can store arbitrary scripts that can lead to persistent cross-site scripting (XSS). The vulnerability affects instances with Splunk Web enabled.

  • CVE-2022-32923MedNov 1, 2022
    risk 0.42cvss 6.5epss 0.01

    A correctness issue in the JIT was addressed with improved checks. This issue is fixed in tvOS 16.1, iOS 15.7.1 and iPadOS 15.7.1, macOS Ventura 13, watchOS 9.1, Safari 16.1, iOS 16.1 and iPadOS 16. Processing maliciously crafted web content may disclose internal states of the…

  • CVE-2022-36783MedOct 25, 2022
    risk 0.42cvss 6.5epss 0.00

    AlgoSec – FireFlow Reflected Cross-Site-Scripting (RXSS) A malicious user injects JavaScript code into a parameter called IntersectudRule on the search/result.html page. The malicious user changes the request from POST to GET and sends the URL to another user (victim).…

  • CVE-2022-2428MedOct 17, 2022
    risk 0.42cvss 6.4epss 0.01

    A crafted tag in the Jupyter Notebook viewer in GitLab EE/CE affecting all versions before 15.1.6, 15.2 to 15.2.4, and 15.3 to 15.3.2 allows an attacker to issue arbitrary HTTP requests

  • CVE-2022-2861MedSep 26, 2022
    risk 0.42cvss 6.5epss 0.01

    Inappropriate implementation in Extensions API in Google Chrome prior to 104.0.5112.101 allowed an attacker who convinced a user to install a malicious extension to inject arbitrary scripts into WebUI via a crafted HTML page.

  • CVE-2022-2937MedSep 23, 2022
    risk 0.42cvss 6.4epss 0.01

    The Image Hover Effects Ultimate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Title & Description values that can be added to an Image Hover in versions up to, and including, 9.7.3 due to insufficient input sanitization and output escaping. This…

  • CVE-2022-36778MedSep 13, 2022
    risk 0.42cvss 6.5epss 0.00

    insert HTML / js code inside input how to get to the vulnerable input : Workers > worker nickname > inject in this input the code.

  • CVE-2022-2936MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Image Hover Effects Ultimate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Video Link values that can be added to an Image Hover in versions up to, and including, 9.7.3 due to insufficient input sanitization and output escaping. This makes it possible…

  • CVE-2022-2935MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Image Hover Effects Ultimate plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Media Image URL value that can be added to an Image Hover in versions up to, and including, 9.7.3 due to insufficient input sanitization and output escaping. This makes it…

  • CVE-2022-2934MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Beaver Builder – WordPress Page Builder for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Image URL' value found in the Media block in versions up to, and including, 2.5.5.2 due to insufficient input sanitization and output escaping. This makes it…

  • CVE-2022-2716MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Beaver Builder – WordPress Page Builder for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Text Editor' block in versions up to, and including, 2.5.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated…

  • CVE-2022-2695MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Beaver Builder – WordPress Page Builder for WordPress is vulnerable to Stored Cross-Site Scripting via the 'caption' parameter added to images via the media uploader in versions up to, and including, 2.5.5.2 due to insufficient input sanitization and output escaping. This…

  • CVE-2022-2517MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Beaver Builder – WordPress Page Builder for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Caption - On Hover' value associated with images in versions up to, and including, 2.5.5.2 due to insufficient input sanitization and output escaping. This makes it…

  • CVE-2022-2516MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Visual Composer Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the post/page 'Title' value in versions up to, and including, 45.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated…

  • CVE-2022-2515MedSep 6, 2022
    risk 0.42cvss 6.4epss 0.01

    The Simple Banner plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `pro_version_activation_code` parameter in versions up to, and including, 2.11.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated…