VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 335 of 2,429
  • CVE-2026-65482MedJul 23, 2026
    risk 0.42cvss 6.5epss 0.00

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LA-Studio LA-Studio Element Kit for Elementor lastudio-element-kit allows DOM-Based XSS.This issue affects LA-Studio Element Kit for Elementor: from n/a through 1.6.3.

  • CVE-2026-65480MedJul 23, 2026
    risk 0.42cvss 6.5epss 0.00

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodexThemes TheGem allows DOM-Based XSS. This issue affects TheGem: from n/a before 5.12.1.1.

  • CVE-2025-13968MedJul 11, 2026
    risk 0.42cvss 6.4epss 0.00

    The Starboard Suite Reservation Calendars plugin for WordPress is vulnerable to Stored Cross-Site Scripting via shortcode attributes in the [starboard-suite-lightbox] shortcode in all versions up to, and including, 3.1.4 due to insufficient input sanitization and output…

  • CVE-2026-53987MedJul 9, 2026
    risk 0.42cvss 6.4epss 0.01

    The Tag plugin for GLPI 11 before 2.14.4 stores the tag name without HTML sanitization and renders it into the Kanban badge markup via PluginTagTag::preKanbanContent() without output escaping, resulting in stored cross-site scripting. An authenticated user with TAG MANAGEMENT…

  • CVE-2025-12799MedJul 7, 2026
    risk 0.42cvss 6.5epss 0.00

    A flaw was found in Jastow. Jastow is vulnerable to Cross-Site Scripting (XSS) attack. If using a set of combined configuration to allow unescaped characters in URL with embedded Undertow and Jastow, a server might be vulnerable to improper input handling.

  • CVE-2026-55660HigJul 1, 2026
    risk 0.42cvss —epss 0.00

    Tina is a headless content management system. In versions prior to @tinacms/app 2.5.6 and tinacms 3.9.3, cross-origin postMessage handlers and a rich-text URL-sanitization bypass enable stored XSS and session takeover. The library registers window message listeners — the…

  • CVE-2026-57737MedJul 1, 2026
    risk 0.42cvss 6.5epss 0.00

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Averta LTD Shortcodes and extra features for Phlox theme auxin-elements allows DOM-Based XSS.This issue affects Shortcodes and extra features for Phlox theme: from n/a through…

  • CVE-2026-12732MedJul 1, 2026
    risk 0.42cvss 6.4epss 0.00

    The LearnPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'class_wrapper_form' shortcode attribute in versions up to, and including, 4.4.0. This is due to insufficient input sanitization and output escaping in the FilterCourseTemplate::sections()…

  • CVE-2026-57963MedJul 1, 2026
    risk 0.42cvss 6.5epss 0.00

    An attacker who can send HTML chat messages (via Matrix or XMPP) can inject arbitrary styled content, phishing links, and CSS that manipulates the chat UI. This vulnerability was fixed in Thunderbird 152.0.1 and Thunderbird 140.12.1.

  • CVE-2025-36320MedJun 30, 2026
    risk 0.42cvss 6.4epss 0.00

    IBM watsonx.data intelligence 5.2.0, 5.2.1, 5.2.2, 5.3.0 is vulnerable to stored cross-site scripting. This vulnerability allows an authenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials…

  • CVE-2026-57618MedJun 26, 2026
    risk 0.42cvss 6.5epss 0.00

    Contributor Cross Site Scripting (XSS) in Neve PRO <= 3.1.2 versions.

  • CVE-2026-57431MedJun 26, 2026
    risk 0.42cvss 6.5epss 0.00

    Author Cross Site Scripting (XSS) in Featured Image <= 2.1 versions.

  • CVE-2026-56046MedJun 26, 2026
    risk 0.42cvss 6.5epss 0.00

    Subscriber Cross Site Scripting (XSS) in ListingPro <= 2.9.11 versions.

  • CVE-2025-68075MedJun 26, 2026
    risk 0.42cvss 6.5epss 0.00

    Contributor Cross Site Scripting (XSS) in BNE Testimonials <= 2.0.8 versions.

  • CVE-2025-68074MedJun 26, 2026
    risk 0.42cvss 6.5epss 0.00

    Contributor Cross Site Scripting (XSS) in Image Carousel <= 1.0.0.41 versions.

  • CVE-2026-53950HigJun 24, 2026
    risk 0.42cvss 7.5epss 0.00

    @tryghost/activitypub is Ghost’s social/federation client app. Prior to 3.1.0, the ActivityPub client in Ghost was vulnerable to JavaScript injection on posts shared by a maliciously customised ActivityPub server. This vulnerability is fixed in 3.1.0.

  • CVE-2026-9620MedJun 24, 2026
    risk 0.42cvss 6.4epss 0.00

    The WP Latest Posts plugin for WordPress is vulnerable to Stored Cross-Site Scripting via crafted image src attributes in post content in versions up to, and including, 5.0.11. This is due to insufficient output escaping in the field() and loop() functions, which extract the raw…

  • CVE-2026-8896MedJun 24, 2026
    risk 0.42cvss 6.4epss 0.00

    The MIR blocks and shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'title' attribute (and other attributes such as 'ready_animation_text') of the 'msc_stats' shortcode in versions up to, and including, 1.0.0. This is due to insufficient input…

  • CVE-2026-8865MedJun 24, 2026
    risk 0.42cvss 6.4epss 0.00

    The Avalon23 Products Filter for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'avalon23_qr' shortcode in all versions up to, and including, 1.1.6. This is due to insufficient input sanitization and output escaping on user-supplied…

  • CVE-2026-11614MedJun 24, 2026
    risk 0.42cvss 6.4epss 0.00

    The Xpro Addons — 140+ Widgets for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'custom_attributes' parameter in all versions up to, and including, 1.7.2 due to insufficient input sanitization and output escaping. This makes it possible…