VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,541)

page 2037 of 2,428
  • CVE-2023-1359LowMar 12, 2023
    risk 0.16cvss 2.4epss 0.01

    A vulnerability has been found in SourceCodester Gadget Works Online Ordering System 1.0 and classified as problematic. This vulnerability affects unknown code of the file /philosophy/admin/user/controller.php?action=add of the component Add New User. The manipulation of the…

  • CVE-2013-10021LowMar 11, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability was found in dd32 Debug Bar Plugin up to 0.8 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function render of the file panels/class-debug-bar-queries.php. The manipulation leads to cross site scripting. The attack can be…

  • CVE-2017-20182LowMar 10, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability was found in Mobile Vikings Django AJAX Utilities up to 1.2.1 and classified as problematic. This issue affects the function Pagination of the file django_ajax/static/ajax-utilities/js/pagination.js of the component Backslash Handler. The manipulation of the…

  • CVE-2013-10020LowMar 10, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability, which was classified as problematic, was found in MMDeveloper A Forms Plugin up to 1.4.2 on WordPress. This affects an unknown part of the file a-forms.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading…

  • CVE-2015-10095LowMar 6, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability classified as problematic has been found in woo-popup Plugin up to 1.2.2 on WordPress. This affects an unknown part of the file admin/class-woo-popup-admin.php. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely.…

  • CVE-2015-10092LowMar 6, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability was found in Qtranslate Slug Plugin up to 1.1.16 on WordPress. It has been classified as problematic. Affected is the function add_slug_meta_box of the file includes/class-qtranslate-slug.php. The manipulation leads to cross site scripting. It is possible to…

  • CVE-2015-10090LowMar 6, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability, which was classified as problematic, has been found in Landing Pages Plugin up to 1.8.7 on WordPress. Affected by this issue is some unknown functionality. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version…

  • CVE-2014-125092LowMar 5, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability was found in MaxButtons Plugin up to 1.26.0 on WordPress and classified as problematic. This issue affects the function maxbuttons_strip_px of the file includes/maxbuttons-button.php. The manipulation of the argument button_id leads to cross site scripting. The…

  • CVE-2006-10001LowMar 5, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability, which was classified as problematic, was found in Subscribe to Comments Plugin up to 2.0.7 on WordPress. This affects an unknown part of the file subscribe-to-comments.php. The manipulation leads to cross site scripting. It is possible to initiate the attack…

  • CVE-2015-10089LowMar 5, 2023
    risk 0.16cvss 3.5epss 0.00

    A vulnerability classified as problematic has been found in flame.js. This affects an unknown part. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. This product does not use versioning. This is why information about affected and…

  • CVE-2008-10002LowMar 5, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability has been found in cfire24 ajaxlife up to 0.3.2 and classified as problematic. This vulnerability affects unknown code. The manipulation leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.3.3 is able to address this issue.…

  • CVE-2014-125090LowMar 4, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability was found in Media Downloader Plugin 0.1.992 on WordPress. It has been declared as problematic. This vulnerability affects the function dl_file_resumable of the file getfile.php. The manipulation of the argument file leads to cross site scripting. The attack can…

  • CVE-2023-1113LowMar 1, 2023
    risk 0.16cvss 2.4epss 0.01

    A vulnerability was found in SourceCodester Simple Payroll System 1.0. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file admin/?page=admin of the component POST Parameter Handler. The manipulation of the argument fullname…

  • CVE-2019-25105LowFeb 26, 2023
    risk 0.16cvss 3.5epss 0.00

    A vulnerability, which was classified as problematic, was found in dro.pm. This affects an unknown part of the file web/fileman.php. The manipulation of the argument secret/key leads to cross site scripting. It is possible to initiate the attack remotely. This product does not…

  • CVE-2023-0966LowFeb 22, 2023
    risk 0.16cvss 2.4epss 0.01

    A vulnerability classified as problematic was found in SourceCodester Online Eyewear Shop 1.0. Affected by this vulnerability is an unknown functionality of the file admin/?page=orders/view_order. The manipulation of the argument id leads to cross site scripting. The attack can…

  • CVE-2014-125089LowFeb 21, 2023
    risk 0.16cvss 3.5epss 0.00

    A vulnerability was found in cention-chatserver 3.8.0-rc1. It has been declared as problematic. Affected by this vulnerability is the function _formatBody of the file lib/InternalChatProtocol.fe. The manipulation of the argument body leads to cross site scripting. The attack can…

  • CVE-2016-15027LowFeb 20, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability was found in meta4creations Post Duplicator Plugin 2.18 on WordPress. It has been classified as problematic. Affected is the function mtphr_post_duplicator_notice of the file includes/notices.php. The manipulation of the argument post-duplicated leads to cross…

  • CVE-2016-15025LowFeb 20, 2023
    risk 0.16cvss 3.5epss 0.01

    A vulnerability, which was classified as problematic, was found in generator-hottowel 0.0.11. Affected is an unknown function of the file app/templates/src/server/_app.js of the component 404 Error Handler. The manipulation leads to cross site scripting. It is possible to launch…

  • CVE-2015-10080LowFeb 20, 2023
    risk 0.16cvss 3.5epss 0.00

    A vulnerability was found in NREL api-umbrella-web 0.7.1. It has been classified as problematic. This affects an unknown part of the component Admin Data Table Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to…

  • CVE-2014-125088LowFeb 20, 2023
    risk 0.16cvss 3.5epss 0.00

    A vulnerability was found in qt-users-jp silk 0.0.1. It has been declared as problematic. This vulnerability affects unknown code of the file contents/root/examples/header.qml. The manipulation of the argument model.key/model.value leads to cross site scripting. The attack can…