VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,541)

page 1998 of 2,428
  • CVE-2021-36864LowOct 28, 2022
    risk 0.22cvss 3.4epss 0.01

    Auth. (editor+) Reflected Cross-Site Scripting (XSS) vulnerability in ExpressTech Quiz And Survey Master plugin <= 7.3.4 on WordPress.

  • CVE-2022-40215LowSep 23, 2022
    risk 0.22cvss 3.4epss 0.01

    Multiple Authenticated Stored Cross-Site Scripting (XSS) vulnerabilities in Tabs plugin <= 3.7.1 at WordPress.

  • CVE-2022-37328LowSep 23, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (author+) Stored Cross-Site Scripting (XSS) vulnerability in Themes Awesome History Timeline plugin <= 1.0.5 at WordPress.

  • CVE-2022-38703LowSep 23, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Max Foundry Button Plugin MaxButtons plugin <= 9.2 at WordPress

  • CVE-2022-36343LowAug 1, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (author or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in ideasToCode Enable SVG, WebP & ICO Upload plugin <= 1.0.1 at WordPress.

  • CVE-2022-30536LowJul 21, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated Stored Cross-Site Scripting (XSS) vulnerability in Florent Maillefaud's WP Maintenance plugin <= 6.0.7 at WordPress.

  • CVE-2021-36849LowJul 20, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in René Hermenau's Social Media Share Buttons plugin <= 3.8.1 at WordPress.

  • CVE-2022-29452LowJun 15, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (editor or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in Export All URLs plugin <= 4.1 at WordPress.

  • CVE-2022-29432LowMay 20, 2022
    risk 0.22cvss 3.4epss 0.01

    Multiple Authenticated (administrator or higher user role) Persistent Cross-Site Scripting (XSS) vulnerabilities in TMS-Plugins wpDataTables plugin <= 2.1.27 on WordPress via &data-link-text, &data-link-url, &data, &data-shortcode, &data-star-num vulnerable parameters.

  • CVE-2021-36844LowMay 2, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in MyThemeShop WP Subscribe plugin <= 1.2.12 on WordPress.

  • CVE-2022-27848LowApr 14, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (admin+ user) Stored Cross-Site Scripting (XSS) in Modern Events Calendar Lite (WordPress plugin) <= 6.5.1

  • CVE-2021-36910LowApr 11, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (admin user role) Stored Cross-Site Scripting (XSS) in WP-Appbox (WordPress plugin) <= 4.3.20.

  • CVE-2021-36848LowApr 11, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Social Media Feather (WordPress plugin) versions <= 2.0.4

  • CVE-2022-25618LowApr 4, 2022
    risk 0.22cvss 3.4epss 0.01

    Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in wpDataTables (WordPress plugin) versions <= 2.1.27

  • CVE-2022-25610LowMar 25, 2022
    risk 0.22cvss 3.4epss 0.01

    Unauthenticated Stored Cross-Site Scripting (XSS) in Simple Ajax Chat <= 20220115 allows an attacker to store the malicious code. However, the attack requires specific conditions, making it hard to exploit.

  • CVE-2021-36889LowDec 20, 2021
    risk 0.22cvss 3.4epss 0.01

    Multiple Stored Authenticated Cross-Site Scripting (XSS) vulnerabilities were discovered in tarteaucitron.js – Cookies legislation & GDPR WordPress plugin (versions <= 1.6).

  • CVE-2020-5265MedApr 20, 2020
    risk 0.22cvss 4.4epss 0.01

    In PrestaShop between versions 1.7.6.1 and 1.7.6.5, there is a reflected XSS on AdminAttributesGroups page. The problem is patched in 1.7.6.5.

  • CVE-2020-5264MedApr 20, 2020
    risk 0.22cvss 4.4epss 0.01

    In PrestaShop before version 1.7.6.5, there is a reflected XSS while running the security compromised page. It allows anyone to execute arbitrary action. The problem is patched in the 1.7.6.5.

  • CVE-2020-5266MedApr 16, 2020
    risk 0.22cvss 4.4epss 0.01

    In the ps_link module for PrestaShop before version 3.1.0, there is a stored XSS when you create or edit a link list block with the title field. The problem is fixed in 3.1.0

  • CVE-2019-3962LowJul 1, 2019
    risk 0.22cvss 3.3epss 0.01

    Content Injection vulnerability in Tenable Nessus prior to 8.5.0 may allow an authenticated, local attacker to exploit this vulnerability by convincing another targeted Nessus user to view a malicious URL and use Nessus to send fraudulent messages. Successful exploitation could…