VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,541)

page 1891 of 2,428
  • CVE-2024-55601MedDec 9, 2024
    risk 0.27cvss —epss 0.01

    Hugo is a static site generator. Starting in version 0.123.0 and prior to version 0.139.4, some HTML attributes in Markdown in the internal templates listed below not escaped in internal render hooks. Those whoa re impacted are Hugo users who do not trust their Markdown content…

  • CVE-2024-11325MedDec 3, 2024
    risk 0.27cvss 5.2epss 0.01

    The AWeber Forms by Optin Cat plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.5.7. This makes it possible for unauthenticated attackers to inject…

  • CVE-2024-53864MedNov 29, 2024
    risk 0.27cvss —epss 0.01

    Ibexa Admin UI Bundle is all the necessary parts to run the Ibexa DXP Back Office interface. The Content name pattern is used to build Content names from one or more fields. An XSS vulnerability has been found in this mechanism. Content edit permission is required to exploit it.…

  • CVE-2024-47819MedOct 22, 2024
    risk 0.27cvss 4.2epss 0.00

    Umbraco, a free and open source .NET content management system, has a cross-site scripting vulnerability starting in version 14.0.0 and prior to versions 14.3.1 and 15.0.0. This can be leveraged to gain access to higher-privilege endpoints, e.g. if you get a user with admin…

  • CVE-2024-45612MedSep 17, 2024
    risk 0.27cvss 5.3epss 0.00

    Contao is an Open Source CMS. In affected versions an untrusted user can inject insert tags into the canonical tag, which are then replaced on the web page (front end). Users are advised to update to Contao 4.13.49, 5.3.15 or 5.4.3. Users unable to upgrade should disable…

  • CVE-2024-6704MedAug 2, 2024
    risk 0.27cvss 5.3epss 0.01

    The Comments – wpDiscuz plugin for WordPress is vulnerable to HTML Injection in all versions up to, and including, 7.6.21. This is due to a lack of filtering of HTML tags in comments. This makes it possible for unauthenticated attackers to add HTML such as hyperlinks to…

  • CVE-2024-31946MedJul 15, 2024
    risk 0.27cvss 4.2epss 0.00

    An issue was discovered in Stormshield Network Security (SNS) 3.7.0 through 3.7.41, 3.10.0 through 3.11.29, 4.0 through 4.3.24, and 4.4.0 through 4.7.4. A user who has access to the SNS with write access on the email alerts page has the ability to create alert email containing…

  • CVE-2024-4176MedJun 13, 2024
    risk 0.27cvss 4.1epss 0.00

    An Cross site scripting vulnerability in the EDR XConsole before this release allowed an attacker to potentially leverage an XSS/HTML-Injection using command line variables. A malicious threat actor could execute commands on the victim's browser for sending carefully crafted…

  • CVE-2024-4456MedMay 8, 2024
    risk 0.27cvss 4.1epss 0.00

    In affected versions of Octopus Server with certain access levels it was possible to embed a Cross-Site Scripting payload on the audit page.

  • CVE-2024-33748MedMay 7, 2024
    risk 0.27cvss 4.1epss 0.00

    Cross-site scripting (XSS) vulnerability in the search function in Maven net.mingsoft MS Basic 2.1.13.4 and earlier.

  • CVE-2024-21066MedApr 16, 2024
    risk 0.27cvss 4.2epss 0.00

    Vulnerability in the RDBMS component of Oracle Database Server. Supported versions that are affected are 19.3-19.22 and 21.3-21.13. Easily exploitable vulnerability allows high privileged attacker having Authenticated User privilege with logon to the infrastructure where RDBMS…

  • CVE-2024-27242MedApr 9, 2024
    risk 0.27cvss 4.1epss 0.00

    Cross site scripting in Zoom Desktop Client for Linux before version 5.17.10 may allow an authenticated user to conduct a denial of service via network access.

  • CVE-2024-29049MedApr 4, 2024
    risk 0.27cvss 4.1epss 0.01

    Microsoft Edge (Chromium-based) Webview2 Spoofing Vulnerability

  • CVE-2024-24742MedFeb 13, 2024
    risk 0.27cvss 4.1epss 0.00

    SAP CRM WebClient UI - version S4FND 102, S4FND 103, S4FND 104, S4FND 105, S4FND 106, WEBCUIF 701, WEBCUIF 731, WEBCUIF 746, WEBCUIF 747, WEBCUIF 748, WEBCUIF 800, WEBCUIF 801, does not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS)…

  • CVE-2024-21738MedJan 9, 2024
    risk 0.27cvss 4.1epss 0.00

    SAP NetWeaver ABAP Application Server and ABAP Platform do not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability. An attacker with low privileges can cause limited impact to confidentiality of the application data after successful…

  • CVE-2023-30959MedSep 27, 2023
    risk 0.27cvss 4.1epss 0.00

    In Apollo change requests, comments added by users could contain a javascript URI link that when rendered will result in an XSS that require user interaction.

  • CVE-2023-38057MedJul 24, 2023
    risk 0.27cvss 4.1epss 0.00

    An improper input validation vulnerability in OTRS Survey modules allows any attacker with a link to a valid and unanswered survey request to inject javascript code in free text answers. This allows a cross site scripting attack while reading the replies as authenticated agent.…

  • CVE-2023-2200MedJul 13, 2023
    risk 0.27cvss 4.1epss 0.00

    An issue has been discovered in GitLab CE/EE affecting all versions starting from 7.14 before 15.11.10, all versions starting from 16.0 before 16.0.6, all versions starting from 16.1 before 16.1.1, which allows an attacker to inject HTML in an email address field.

  • CVE-2023-34121MedJun 13, 2023
    risk 0.27cvss 4.1epss 0.01

    Improper input validation in the Zoom for Windows, Zoom Rooms, Zoom VDI Windows Meeting clients before 5.14.0 may allow an authenticated user to potentially enable an escalation of privilege via network access.

  • CVE-2022-32970MedMay 10, 2023
    risk 0.27cvss 4.1epss 0.00

    Auth. (editor+) Stored Cross-Site Scripting (XSS) vulnerability in Themify Themify Portfolio Post plugin <= 1.2.4 versions.