VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 1863 of 2,429
  • CVE-2024-32077MedMay 14, 2024
    risk 0.28cvss 5.4epss 0.02

    Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.

  • CVE-2024-3956MedMay 14, 2024
    risk 0.28cvss 5.4epss 0.00

    The Pods – Custom Content Types and Fields plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Pod Form widget in all versions up to, and including, 3.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes…

  • CVE-2024-34899MedMay 14, 2024
    risk 0.28cvss 5.4epss 0.00

    WWBN AVideo 12.4 is vulnerable to Cross Site Scripting (XSS).

  • CVE-2024-34341MedMay 7, 2024
    risk 0.28cvss 5.4epss 0.01

    Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content,…

  • CVE-2024-34064MedMay 6, 2024
    risk 0.28cvss 5.4epss 0.01

    Jinja is an extensible templating engine. The `xmlattr` filter in affected versions of Jinja accepts keys containing non-attribute characters. XML/HTML attributes cannot contain spaces, `/`, `>`, or `=`, as each would then be interpreted as starting a separate attribute. If an…

  • CVE-2024-4203MedMay 2, 2024
    risk 0.28cvss 5.4epss 0.00

    The Premium Addons Pro for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the maps widget in all versions up to, and including, 4.10.30 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible…

  • CVE-2024-3340MedMay 2, 2024
    risk 0.28cvss 5.4epss 0.00

    The Colibri Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'colibri-gallery-slideshow' shortcode in all versions up to, and including, 1.0.272 due to insufficient input sanitization and output escaping on user supplied attributes.…

  • CVE-2024-2765MedMay 2, 2024
    risk 0.28cvss 5.4epss 0.01

    The Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Skype and Spotify URL parameters in all versions up to, and including, 2.8.4 due to…

  • CVE-2024-4348MedApr 30, 2024
    risk 0.28cvss 4.3epss 0.02

    A vulnerability, which was classified as problematic, was found in osCommerce 4. Affected is an unknown function of the file /catalog/all-products. The manipulation of the argument cat leads to cross site scripting. It is possible to launch the attack remotely. The exploit has…

  • CVE-2024-2908MedApr 26, 2024
    risk 0.28cvss 4.3epss 0.01

    The Call Now Button WordPress plugin before 1.4.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in…

  • CVE-2024-3994MedApr 25, 2024
    risk 0.28cvss 5.4epss 0.00

    The Tutor LMS – eLearning and online course solution plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'tutor_instructor_list' shortcode in all versions up to, and including, 2.6.2 due to insufficient input sanitization and output escaping on…

  • CVE-2022-34561MedApr 22, 2024
    risk 0.28cvss 4.3epss 0.00

    A cross-site scripting (XSS) vulnerability in PHPFox v4.8.9 allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the video description parameter.

  • CVE-2024-3818MedApr 19, 2024
    risk 0.28cvss 5.4epss 0.00

    The Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's "Social Icons" block in all versions up to, and including, 4.5.9 due to insufficient input sanitization and output…

  • CVE-2024-32333MedApr 18, 2024
    risk 0.28cvss 4.3epss 0.01

    TOTOLINK N300RT V2.1.8-B20201030.1539 contains a Store Cross-site scripting (XSS) vulnerability in MAC Filtering under the Firewall Page.

  • CVE-2024-2733MedApr 10, 2024
    risk 0.28cvss 5.4epss 0.01

    The Bold Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's "Separator" element in all versions up to, and including, 4.8.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible…

  • CVE-2024-28190MedApr 9, 2024
    risk 0.28cvss 5.4epss 0.01

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, users can inject malicious code in filenames when uploading files (back end and front end), which is then executed in tooltips and popups in the back end. Contao…

  • CVE-2024-3377MedApr 6, 2024
    risk 0.28cvss 4.3epss 0.01

    A vulnerability classified as problematic was found in SourceCodester Computer Laboratory Management System 1.0. This vulnerability affects unknown code of the file /classes/SystemSettings.php?f=update_settings. The manipulation of the argument name leads to cross site…

  • CVE-2024-3086MedMar 30, 2024
    risk 0.28cvss 4.3epss 0.01

    A vulnerability classified as problematic was found in PHPGurukul Emergency Ambulance Hiring Portal 1.0. Affected by this vulnerability is an unknown functionality of the file ambulance-tracking.php of the component Ambulance Tracking Page. The manipulation of the argument…

  • CVE-2024-3084MedMar 30, 2024
    risk 0.28cvss 4.3epss 0.01

    A vulnerability was found in PHPGurukul Emergency Ambulance Hiring Portal 1.0. It has been rated as problematic. This issue affects some unknown processing of the component Hire an Ambulance Page. The manipulation of the argument Patient Name/Relative Name/Relative Phone…

  • CVE-2024-2732MedMar 26, 2024
    risk 0.28cvss 5.4epss 0.00

    The Themify Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'themify_post_slider shortcode in all versions up to, and including, 2.0.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes…