VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 1859 of 2,429
  • CVE-2024-38815MedOct 9, 2024
    risk 0.28cvss 4.3epss 0.00

    VMware NSX contains a content spoofing vulnerability.  An unauthenticated malicious actor may be able to craft a URL and redirect a victim to an attacker controlled domain leading to sensitive information disclosure.

  • CVE-2024-45292MedOct 7, 2024
    risk 0.28cvss 5.4epss 0.00

    PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. `\PhpOffice\PhpSpreadsheet\Writer\Html` does not sanitize "javascript:" URLs from hyperlink `href` attributes, resulting in a Cross-Site Scripting vulnerability. This issue has been addressed in…

  • CVE-2024-47618MedOct 3, 2024
    risk 0.28cvss 5.4epss 0.00

    Sulu is a PHP content management system. Sulu is vulnerable against XSS whereas a low privileged user with access to the “Media” section can upload an SVG file with a malicious payload. Once uploaded and accessed, the malicious javascript will be executed on the victims’…

  • CVE-2024-9440MedOct 2, 2024
    risk 0.28cvss 5.4epss 0.00

    Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to…

  • CVE-2024-47536MedSep 30, 2024
    risk 0.28cvss 5.4epss 0.00

    Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. A user with the editmyprivateinfo right or who can otherwise change their name can XSS themselves by setting their "real name" to an XSS payload. This vulnerability is fixed in 2.31.0.

  • CVE-2024-9300MedSep 28, 2024
    risk 0.28cvss 4.3epss 0.01

    A vulnerability classified as problematic was found in SourceCodester Online Railway Reservation System 1.0. This vulnerability affects unknown code of the file contact_us.php of the component Message Us Form. The manipulation of the argument fullname/email/message leads to…

  • CVE-2024-7398MedSep 25, 2024
    risk 0.28cvss 5.4epss 0.00

    Concrete CMS versions 9 through 9.3.3 and versions below 8.5.19 are vulnerable to stored XSS in the calendar event addition feature because the calendar event name was not sanitized on output. Users or groups with permission to create event calendars can embed scripts, and users…

  • CVE-2024-8628MedSep 24, 2024
    risk 0.28cvss 5.4epss 0.00

    The Popup, Optin Form & Email Newsletters for Mailchimp, HubSpot, AWeber – MailOptin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'post-meta' shortcode in all versions up to, and including, 1.2.70.3 due to insufficient input sanitization…

  • CVE-2024-38221MedSep 19, 2024
    risk 0.28cvss 4.3epss 0.00

    Microsoft Edge (Chromium-based) Spoofing Vulnerability

  • CVE-2024-47050MedSep 18, 2024
    risk 0.28cvss 5.4epss 0.00

    Prior to this patch being applied, Mautic's tracking was vulnerable to Cross-Site Scripting through the Page URL variable.

  • CVE-2024-39910MedSep 16, 2024
    risk 0.28cvss 5.4epss 0.00

    decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The WYSWYG editor QuillJS is subject to potential XSS attach in case the attacker manages to modify the HTML before being uploaded to the server. The…

  • CVE-2024-8866MedSep 15, 2024
    risk 0.28cvss 4.3epss 0.01

    A vulnerability was found in AutoCMS 5.4. It has been classified as problematic. This affects an unknown part of the file /admin/robot.php. The manipulation of the argument sidebar leads to cross site scripting. It is possible to initiate the attack remotely. The exploit has…

  • CVE-2024-39926MedSep 13, 2024
    risk 0.28cvss 5.4epss 0.00

    An issue was discovered in Vaultwarden (formerly Bitwarden_RS) 1.30.3. A stored cross-site scripting (XSS) or, due to the default CSP, HTML injection vulnerability has been discovered in the admin dashboard. This potentially allows an authenticated attacker to inject malicious…

  • CVE-2020-24061MedSep 12, 2024
    risk 0.28cvss 4.3epss 0.00

    Cross Site Scripting (XSS) Vulnerability in Firewall menu in Control Panel in KASDA KW5515 version 4.3.1.0, allows attackers to execute arbitrary code and steal cookies via a crafted script

  • CVE-2024-5416MedSep 11, 2024
    risk 0.28cvss 5.4epss 0.00

    The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the url parameter of multiple widgets in all versions up to, and including, 3.23.4 due to insufficient input sanitization and output escaping on…

  • CVE-2024-6282MedSep 10, 2024
    risk 0.28cvss 5.4epss 0.00

    The Master Addons – Free Widgets, Hover Effects, Toggle, Conditions, Animations for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the data-jltma-wrapper-link element in all versions up to, and including 2.0.6.4 due to insufficient input…

  • CVE-2024-8605MedSep 9, 2024
    risk 0.28cvss 4.3epss 0.01

    A vulnerability classified as problematic was found in code-projects Inventory Management 1.0. This vulnerability affects unknown code of the file /view/registration.php of the component Registration Form. The manipulation with the input leads to cross…

  • CVE-2024-8604MedSep 9, 2024
    risk 0.28cvss 4.3epss 0.01

    A vulnerability classified as problematic has been found in SourceCodester Online Food Ordering System 2.0. This affects an unknown part of the file index.php of the component Create an Account Page. The manipulation of the argument First Name/Last Name leads to cross site…

  • CVE-2024-7687MedSep 9, 2024
    risk 0.28cvss 4.3epss 0.00

    The AZIndex WordPress plugin through 0.8.1 does not have CSRF check in some places, and is missing sanitisation as well as escaping, which could allow attackers to make logged in admin add Stored XSS payloads via a CSRF attack.

  • CVE-2024-8566MedSep 8, 2024
    risk 0.28cvss 4.3epss 0.00

    A vulnerability classified as problematic was found in code-projects Online Shop Store 1.0. This vulnerability affects unknown code of the file /settings.php. The manipulation of the argument error leads to cross site scripting. The attack can be initiated remotely. The exploit…