VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 1818 of 2,429
  • CVE-2023-5621MedOct 18, 2023
    risk 0.29cvss 4.4epss 0.00

    The Thumbnail Slider With Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Image Title field in versions up to, and including, 1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers,…

  • CVE-2023-1259MedOct 14, 2023
    risk 0.29cvss 4.4epss 0.01

    The Hotjar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the hotjar_site_id in versions up to, and including, 1.0.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level…

  • CVE-2023-4160MedAug 31, 2023
    risk 0.29cvss 4.4epss 0.00

    The WooCommerce PDF Invoice Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 1.2.90 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…

  • CVE-2023-38188MedAug 8, 2023
    risk 0.29cvss 4.5epss 0.01

    Azure Apache Hadoop Spoofing Vulnerability

  • CVE-2023-36881MedAug 8, 2023
    risk 0.29cvss 4.5epss 0.01

    Azure Apache Ambari Spoofing Vulnerability

  • CVE-2023-36877MedAug 8, 2023
    risk 0.29cvss 4.5epss 0.01

    Azure Apache Oozie Spoofing Vulnerability

  • CVE-2023-35393MedAug 8, 2023
    risk 0.29cvss 4.5epss 0.01

    Azure Apache Hive Spoofing Vulnerability

  • CVE-2023-3369MedJul 12, 2023
    risk 0.29cvss 4.4epss 0.00

    The About Me 3000 widget plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 2.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…

  • CVE-2023-36828MedJul 5, 2023
    risk 0.29cvss 5.5epss 0.01

    Statamic is a flat-first, Laravel and Git powered content management system. Prior to version 4.10.0, the SVG tag does not sanitize malicious SVG. Therefore, an attacker can exploit this vulnerability to perform cross-site scripting attacks using SVG, even when using the…

  • CVE-2023-2767MedJun 9, 2023
    risk 0.29cvss 4.4epss 0.00

    The WordPress File Upload and WordPress File Upload Pro plugins for WordPress are vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 4.19.1 due to insufficient input sanitization and output escaping. This makes it possible for…

  • CVE-2023-2584MedJun 9, 2023
    risk 0.29cvss 4.4epss 0.01

    The PixelYourSite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 9.3.6 (9.6.1 in the Pro version) due to insufficient input sanitization and output escaping. This makes it possible for authenticated…

  • CVE-2023-2452MedJun 9, 2023
    risk 0.29cvss 4.4epss 0.01

    The Advanced Woo Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 2.77 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…

  • CVE-2023-2015MedJun 7, 2023
    risk 0.29cvss 4.4epss 0.01

    An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.8 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A reflected XSS was possible when creating new abuse reports which allows…

  • CVE-2023-2836MedMay 31, 2023
    risk 0.29cvss 4.4epss 0.01

    The CRM Perks Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via form settings in versions up to, and including, 1.1.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…

  • CVE-2023-2436MedMay 31, 2023
    risk 0.29cvss 4.4epss 0.00

    The Blog-in-Blog plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'blog_in_blog' shortcode in versions up to, and including, 2.0.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for…

  • CVE-2023-33196MedMay 26, 2023
    risk 0.29cvss 5.5epss 0.01

    Craft is a CMS for creating custom digital experiences. Cross site scripting (XSS) can be triggered by review volumes. This issue has been fixed in version 4.4.7.

  • CVE-2023-33197MedMay 26, 2023
    risk 0.29cvss 5.5epss 0.01

    Craft is a CMS for creating custom digital experiences on the web. Cross-site scripting (XSS) can be triggered via the Update Asset Index utility. This issue has been patched in version 4.4.6.

  • CVE-2023-1836MedMay 3, 2023
    risk 0.29cvss 4.4epss 0.01

    A cross-site scripting issue has been discovered in GitLab affecting all versions starting from 5.1 before 15.9.6, all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. When viewing an XML file in a repository in "raw" mode, it can be…

  • CVE-2023-28477MedApr 28, 2023
    risk 0.29cvss 5.5epss 0.01

    Concrete CMS (previously concrete5) versions 8.5.12 and below, and 9.0 through 9.1.3 is vulnerable to stored XSS on API Integrations via the name parameter.

  • CVE-2023-1913MedApr 6, 2023
    risk 0.29cvss 4.4epss 0.00

    The Maps Widget for Google Maps for WordPress is vulnerable to Stored Cross-Site Scripting via widget settings in versions up to, and including, 4.24 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…