VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,562)

page 1803 of 2,429
  • CVE-2018-10937MedSep 11, 2018
    risk 0.30cvss 4.6epss 0.01

    A cross site scripting flaw exists in the tetonic-console component of Openshift Container Platform 3.11. An attacker with the ability to create pods can use this flaw to perform actions on the K8s API as the victim.

  • CVE-2017-7437MedMar 5, 2018
    risk 0.30cvss 4.6epss 0.01

    NetIQ Privileged Account Manager before 3.1 Patch Update 3 allowed cross site scripting attacks via the "type" and "account" parameters of json requests.

  • CVE-2017-7438MedMar 2, 2018
    risk 0.30cvss 4.6epss 0.01

    NetIQ Privileged Account Manager before 3.1 Patch Update 3 allowed cross site scripting attacks via javascript DOM modification using the supplied cookie parameter.

  • CVE-2017-7419MedMar 2, 2018
    risk 0.30cvss 4.6epss 0.01

    A OAuth application in NetIQ Access Manager 4.3 before 4.3.2 and 4.2 before 4.2.4 allowed cross site scripting attacks due to unescaped "description" field that could be specified by the provider.

  • CVE-2017-14801MedMar 2, 2018
    risk 0.30cvss 4.6epss 0.01

    Reflected XSS in the NetIQ Access Manager before 4.3.3 allowed attackers to reflect back xss into the called page using the url parameter.

  • CVE-2017-14799MedMar 1, 2018
    risk 0.30cvss 4.6epss 0.01

    A cross site scripting attack in handling the ESP login parameter handling in NetIQ Access Manager before 4.3.3 could be used to inject javascript code into the login page.

  • CVE-2011-4346MedDec 10, 2011
    risk 0.30cvss 4.6epss 0.01

    Cross-site scripting (XSS) vulnerability in the web interface in Red Hat Network (RHN) Satellite allows remote authenticated users to inject arbitrary web script or HTML via the Description field of the asset tag in a Custom Info page.

  • CVE-2026-1645MedSep 22, 2026
    risk 0.29cvss 4.4epss 0.00

    The Hostel plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'custom_currency' parameter and the 'locale_url' setting in all versions up to, and including, 1.1.8 due to insufficient input sanitization and output escaping. This makes it possible for…

  • CVE-2026-12402MedSep 19, 2026
    risk 0.29cvss 4.4epss 0.00

    The OTP Login & Register Woocommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'fb-config' Setting in all versions up to, and including, 2.7.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated…

  • CVE-2026-12042MedSep 19, 2026
    risk 0.29cvss 4.4epss 0.00

    The WP2Social Auto Publish plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.4.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…

  • CVE-2025-13533MedSep 18, 2026
    risk 0.29cvss 4.4epss 0.00

    The CSS & JavaScript Toolbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 12.0.6 via the Assignment Engine fields. This is due to insufficient input sanitization and output escaping on assignment data fields including…

  • CVE-2026-88055MedSep 10, 2026
    risk 0.29cvss 5.5epss 0.00

    AnythingLLM is an application that turns pieces of content into context that any LLM can use as references during chatting. In 1.16.1 and earlier, the manager role can store meta_page_title or meta_page_favicon through /api/admin/system-preferences, and MetaGenerator inserts…

  • CVE-2026-52772MedSep 5, 2026
    risk 0.29cvss 5.5epss 0.00

    YesWiki is a wiki system written in PHP. Prior to version 4.6.6, Bazar form-field templates still apply |raw('html') to field.label / field.hint in attribute and label-body contexts, resulting stored XSS in form renders. This issue has been patched in version 4.6.6.

  • CVE-2026-77643MedAug 20, 2026
    risk 0.29cvss 4.4epss 0.00

    A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 2.1.0 and before 1.4.32 exists due to incomplete HTML escaping by Xapian::MSet::snippet(). NOTE: this issue exists because of a missed corner case of CVE-2018-0499.

  • CVE-2026-75059MedAug 17, 2026
    risk 0.29cvss 4.4epss 0.00

    In JetBrains PyCharm before 2026.2.1 code execution via Quick Documentation was possible

  • CVE-2026-12477MedAug 16, 2026
    risk 0.29cvss 4.4epss 0.00

    The Gravity Booster – Styles & Layouts for Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 5.26 due to insufficient input sanitization and output escaping. This makes it possible for…

  • CVE-2026-2487MedAug 16, 2026
    risk 0.29cvss 4.4epss 0.00

    The Admin Custom Login plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.6.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with…

  • CVE-2026-5116MedAug 5, 2026
    risk 0.29cvss 4.4epss 0.00

    The Contact Form 7 – Dynamic Text Extension plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 5.0.5. This is due to insufficient output escaping on form shortcode keys displayed in the admin "Scan Forms for Post Meta and…

  • CVE-2026-5108MedAug 5, 2026
    risk 0.29cvss 4.4epss 0.00

    The Super Progressive Web Apps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `superpwa_settings[offline_message_txt]` setting in all versions up to, and including, 2.2.43. This is due to insufficient input sanitization and output escaping. The offline…

  • CVE-2026-12041MedJul 8, 2026
    risk 0.29cvss 4.4epss 0.00

    The Chatra Live Chat + ChatBot + Cart Saver plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 1.0.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated…