VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1728 of 2,429
  • CVE-2022-0598MedAug 1, 2022
    risk 0.31cvss 4.8epss 0.01

    The Login with phone number WordPress plugin before 1.3.8 does not sanitise and escape plugin settings which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-36378MedJul 29, 2022
    risk 0.31cvss 4.8epss 0.01

    Authenticated (author or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in PluginlySpeaking Floating Div plugin <= 3.0 at WordPress.

  • CVE-2022-35632MedJul 29, 2022
    risk 0.31cvss 4.8epss 0.00

    The Velociraptor GUI contains an editor suggestion feature that can display the description field of a VQL function, plugin or artifact. This field was not properly sanitized and can lead to cross-site scripting (XSS). This issue was resolved in Velociraptor 0.6.5-2.

  • CVE-2022-34580MedJul 28, 2022
    risk 0.31cvss 4.8epss 0.01

    Advanced School Management System v1.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the address parameter at ip/school/index.php.

  • CVE-2022-35882MedJul 28, 2022
    risk 0.31cvss 4.8epss 0.01

    Authenticated (author or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in GS Plugins GS Testimonial Slider plugin <= 1.9.5 at WordPress.

  • CVE-2022-34594MedJul 27, 2022
    risk 0.31cvss 4.8epss 0.01

    Advanced School Management System v1.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the component ip/school/moudel/update_subject.php. This vulnerability allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the…

  • CVE-2022-2341MedJul 25, 2022
    risk 0.31cvss 4.8epss 0.01

    The Simple Page Transition WordPress plugin through 1.4.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in…

  • CVE-2022-2340MedJul 25, 2022
    risk 0.31cvss 4.8epss 0.01

    The W-DALIL WordPress plugin through 2.0 does not sanitise and escape some of its fields, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)

  • CVE-2022-35569MedJul 20, 2022
    risk 0.31cvss 4.8epss 0.01

    Blogifier v3.0 was discovered to contain an arbitrary file upload vulnerability at /api/storage/upload/PostImage. This vulnerability allows attackers to execute arbitrary web scripts or HTML via a crafted file.

  • CVE-2022-23438MedJul 18, 2022
    risk 0.31cvss 4.7epss 0.01

    An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability in FortiOS version 7.0.5 and prior and 6.4.9 and prior may allow an unauthenticated remote attacker to perform a reflected cross site scripting (XSS) attack in the…

  • CVE-2022-2194MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The Accept Stripe Payments WordPress plugin before 2.0.64 does not sanitize and escape some of its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-2186MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The Simple Post Notes WordPress plugin before 1.7.6 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-2169MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The Loading Page with Loading Screen WordPress plugin before 1.0.83 does not escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-2151MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The Best Contact Management Software WordPress plugin through 3.7.3 does not sanitise and escape its settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-2149MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The Very Simple Breadcrumb WordPress plugin through 1.0 does not sanitise and escape its settings, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-2148MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The LinkedIn Company Updates WordPress plugin through 1.5.3 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-2118MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The 404s WordPress plugin before 3.5.1 does not sanitise and escape its fields, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2022-2114MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The Data Tables Generator by Supsystic WordPress plugin before 1.10.20 does not sanitise and escape some of its Table settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed…

  • CVE-2022-2100MedJul 17, 2022
    risk 0.31cvss 4.8epss 0.01

    The Page Generator WordPress plugin before 1.6.5 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

  • CVE-2020-21967MedJul 13, 2022
    risk 0.31cvss 4.8epss 0.01

    File upload vulnerability in the Catalog feature in Prestashop 1.7.6.7 allows remote attackers to run arbitrary code via the add new file page.