VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,563)

page 1647 of 2,429
  • CVE-2019-17496MedOct 11, 2019
    risk 0.33cvss 6.1epss 0.01

    Craft CMS before 3.3.8 has stored XSS via a name field. This field is mishandled during site deletion.

  • CVE-2015-9472MedOct 10, 2019
    risk 0.33cvss 6.1epss 0.01

    The incoming-links plugin before 0.9.10b for WordPress has referrers.php XSS via the Referer HTTP header.

  • CVE-2019-17427MedOct 10, 2019
    risk 0.33cvss 6.1epss 0.02

    In Redmine before 3.4.11 and 4.0.x before 4.0.4, persistent XSS exists due to textile formatting errors.

  • CVE-2019-17092MedOct 9, 2019
    risk 0.33cvss 6.1epss 0.02

    An XSS vulnerability in project list in OpenProject before 9.0.4 and 10.x before 10.0.2 allows remote attackers to inject arbitrary web script or HTML via the sortBy parameter because error messages are mishandled.

  • CVE-2019-17179MedOct 4, 2019
    risk 0.33cvss 6.1epss 0.01

    4.1.0, 4.1.1, 4.1.2, 4.1.2.3, 4.1.2.6, 4.1.2.7, 4.2.0, 4.2.1, 4.2.2, 5.0.0, 5.0.0.5, 5.0.0.6, 5.0.1, 5.0.1.1, 5.0.1.2, 5.0.1.3, 5.0.1.4, 5.0.1.5, 5.0.1.6, 5.0.1.7, 5.0.2, fixed in version 5.0.2.1

  • CVE-2019-17091MedOct 2, 2019
    risk 0.33cvss 6.1epss 0.02

    faces/context/PartialViewContextImpl.java in Eclipse Mojarra, as used in Mojarra for Eclipse EE4J before 2.3.10 and Mojarra JavaServer Faces before 2.2.20, allows Reflected XSS because a client window field is mishandled.

  • CVE-2019-16935MedSep 28, 2019
    risk 0.33cvss 6.1epss 0.05

    The documentation XML-RPC server in Python through 2.7.16, 3.x through 3.6.9, and 3.7.x through 3.7.4 has XSS via the server_title field. This occurs in Lib/DocXMLRPCServer.py in Python 2.x, and in Lib/xmlrpc/server.py in Python 3.x. If set_server_title is called with untrusted…

  • CVE-2019-16914MedSep 26, 2019
    risk 0.33cvss 6.1epss 0.02

    An XSS issue was discovered in pfSense through 2.4.4-p3. In services_captiveportal_mac.php, the username and delmac parameters are displayed without sanitization.

  • CVE-2017-18635MedSep 25, 2019
    risk 0.33cvss 6.1epss 0.05

    An XSS vulnerability was discovered in noVNC before 0.6.2 in which the remote VNC server could inject arbitrary HTML into the noVNC web page via the messages propagated to the status field, such as the VNC server name.

  • CVE-2019-12205MedSep 25, 2019
    risk 0.33cvss 6.1epss 0.01

    SilverStripe through 4.3.3 has Flash Clipboard Reflected XSS.

  • CVE-2019-10405MedSep 25, 2019
    risk 0.33cvss 5.4epss 0.65

    Jenkins 2.196 and earlier, LTS 2.176.3 and earlier printed the value of the "Cookie" HTTP request header on the /whoAmI/ URL, allowing attackers exploiting another XSS vulnerability to obtain the HTTP session cookie despite it being marked HttpOnly.

  • CVE-2019-16728MedSep 24, 2019
    risk 0.33cvss 6.1epss 0.01

    DOMPurify before 2.0.1 allows XSS because of innerHTML mutation XSS (mXSS) for an SVG element or a MATH element, as demonstrated by Chrome and Safari.

  • CVE-2015-9405MedSep 20, 2019
    risk 0.33cvss 6.1epss 0.01

    The wp-piwik plugin before 1.0.5 for WordPress has XSS.

  • CVE-2016-11013MedSep 20, 2019
    risk 0.33cvss 6.1epss 0.01

    The wp-listings plugin before 2.0.2 for WordPress has includes/views/single-listing.php XSS.

  • CVE-2016-10970MedSep 16, 2019
    risk 0.33cvss 6.1epss 0.01

    The supportflow plugin before 0.7 for WordPress has XSS via a ticket excerpt.

  • CVE-2016-10969MedSep 16, 2019
    risk 0.33cvss 6.1epss 0.01

    The supportflow plugin before 0.7 for WordPress has XSS via a discussion ticket title.

  • CVE-2016-10941MedSep 13, 2019
    risk 0.33cvss 6.1epss 0.01

    The podlove-podcasting-plugin-for-wordpress plugin before 2.3.16 for WordPress has XSS exploitable via CSRF.

  • CVE-2019-16222MedSep 11, 2019
    risk 0.33cvss 6.1epss 0.02

    WordPress before 5.2.3 has an issue with URL sanitization in wp_kses_bad_protocol_once in wp-includes/kses.php that can lead to cross-site scripting (XSS) attacks.

  • CVE-2019-16221MedSep 11, 2019
    risk 0.33cvss 6.1epss 0.02

    WordPress before 5.2.3 allows reflected XSS in the dashboard.

  • CVE-2019-16219MedSep 11, 2019
    risk 0.33cvss 6.1epss 0.02

    WordPress before 5.2.3 allows XSS in shortcode previews.