VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,564)

page 1063 of 2,429
  • CVE-2021-41248HigNov 4, 2021
    risk 0.39cvss 7.1epss 0.01

    GraphiQL is the reference implementation of this monorepo, GraphQL IDE, an official project under the GraphQL Foundation. All versions of graphiql older than [email protected] are vulnerable to compromised HTTP schema introspection responses or schema prop values with malicious…

  • CVE-2021-41249HigNov 4, 2021
    risk 0.39cvss 7.1epss 0.01

    GraphQL Playground is a GraphQL IDE for development of graphQL focused applications. All versions of graphql-playground-react older than [email protected] are vulnerable to compromised HTTP schema introspection responses or schema prop values with malicious GraphQL…

  • CVE-2021-41184MedOct 26, 2021
    risk 0.39cvss 6.5epss 0.41

    jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `of` option of the `.position()` util from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `of`…

  • CVE-2021-28114MedJul 16, 2021
    risk 0.39cvss 5.4epss 0.52

    Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.

  • CVE-2021-30119MedJul 9, 2021
    risk 0.39cvss 5.4epss 0.59

    Authenticated reflective XSS in HelpDeskTab/rcResults.asp The parameter result of /HelpDeskTab/rcResults.asp is insecurely returned in the requested web page and can be used to perform a Cross Site Scripting attack Example request: `https://x.x.x.x/HelpDeskTab/rcResults.asp?resul…

  • CVE-2021-32735HigJul 2, 2021
    risk 0.39cvss 7.1epss 0.01

    Kirby is a content management system. In Kirby CMS versions 3.5.5 and 3.5.6, the Panel's `ListItem` component (used in the pages and files section for example) displayed HTML in page titles as it is. This could be used for cross-site scripting (XSS) attacks. Malicious…

  • CVE-2021-3355MedFeb 24, 2021
    risk 0.39cvss 5.4epss 0.07

    A stored-self XSS exists in LightCMS v1.3.4, allowing an attacker to execute HTML or JavaScript code in a vulnerable Title field to /admin/SensitiveWords.

  • CVE-2020-13947MedFeb 8, 2021
    risk 0.39cvss 6.1epss 0.79

    An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console on the message.jsp page of Apache ActiveMQ versions 5.15.12 through 5.16.0.

  • CVE-2020-35807MedDec 30, 2020
    risk 0.39cvss 6.0epss 0.01

    Certain NETGEAR devices are affected by stored XSS. This affects D7800 before 1.0.1.56, R7800 before 1.0.2.68, RAX120 before 1.0.0.78, RBK22 before 2.3.5.26, RBR20 before 2.3.5.26, RBS20 before 2.3.5.26, RBK40 before 2.3.5.30, RBR40 before 2.3.5.30, RBS40 before 2.3.5.30, RBK50…

  • CVE-2020-35806MedDec 30, 2020
    risk 0.39cvss 6.0epss 0.00

    Certain NETGEAR devices are affected by stored XSS. This affects D7800 before 1.0.1.56, R7500v2 before 1.0.3.46, R7800 before 1.0.2.68, RAX120 before 1.0.0.78, RBK22 before 2.3.5.26, RBR20 before 2.3.5.26, RBS20 before 2.3.5.26, RBK40 before 2.3.5.30, RBR40 before 2.3.5.30,…

  • CVE-2020-7776HigDec 9, 2020
    risk 0.39cvss 7.1epss 0.01

    This affects the package phpoffice/phpspreadsheet from 0.0.0. The library is vulnerable to XSS when creating an html output from an excel file by adding a comment on any cell. The root cause of this issue is within the HTML writer where user comments are concatenated as part of…

  • CVE-2020-26915MedOct 9, 2020
    risk 0.39cvss 6.0epss 0.01

    Certain NETGEAR devices are affected by stored XSS. This affects D7800 before 1.0.1.56, R7500v2 before 1.0.3.46, R7800 before 1.0.2.68, R8900 before 1.0.4.28, R9000 before 1.0.4.28, RAX120 before 1.0.0.78, RBK50 before 2.3.5.30, RBR50 before 2.3.5.30, RBS50 before 2.3.5.30,…

  • CVE-2016-1000241higSep 1, 2020
    risk 0.39cvss —epss 0.01

    Affected versions of `pivottable` are vulnerable to cross-site scripting, due to a new mechanism used to render JSON elements. ## Recommendation Update to version 2.0.0 or later.

  • CVE-2016-1000235higSep 1, 2020
    risk 0.39cvss —epss 0.01

    Affected versions of `fuelux` contain a cross-site scripting vulnerability in the Pillbox feature. By supplying a script as a value for a new pillbox, it is possible to cause arbitrary script execution. ## Recommendation Update to version 3.15.7 or later.

  • CVE-2016-1000233higSep 1, 2020
    risk 0.39cvss —epss 0.01

    Affected versions of `swagger-ui` are vulnerable to cross-site scripting. This vulnerability exists because `swagger-ui` automatically executes external Javascript that is loaded in via the `url` query string parameter when a `Content-Type: application/javascript` header is…

  • CVE-2016-1000231higSep 1, 2020
    risk 0.39cvss —epss 0.01

    Affected versions of `emojione` are vulnerable to cross-site scripting when user input is passed into the `toShort()`, `shortnameToImage()`, `unicodeToImage()`, and `toImage()` functions. ## Recommendation Update to version 1.3.1 or later.

  • CVE-2016-1000230higSep 1, 2020
    risk 0.39cvss —epss 0.01

    Affected versions of `rendr` are vulnerable to cross-site scripting when client side rendering is done inside a `_block`. Server side rendering is not affected and is properly escaped. ## Recommendation Update to version 1.1.4 or later.

  • CVE-2016-1000228higSep 1, 2020
    risk 0.39cvss —epss 0.01

    Affected versions of `gmail-js` are vulnerable to cross-site scripting in the `tools.parse_response`, `helper.get.visible_emails_post`, and `helper.get.email_data_post` functions, which pass user input directly into the Function constructor. ## Recommendation Update to…

  • CVE-2020-11062MedMay 12, 2020
    risk 0.39cvss 6.0epss 0.01

    In GLPI after 0.68.1 and before 9.4.6, multiple reflexive XSS occur in Dropdown endpoints due to an invalid Content-Type. This has been fixed in version 9.4.6.

  • CVE-2020-11457MedApr 1, 2020
    risk 0.39cvss 5.4epss 0.09

    pfSense before 2.4.5 has stored XSS in system_usermanager_addprivs.php in the WebGUI via the descr parameter (aka full name) of a user.