VYPR

CWE-79

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

BaseStableLikelihood: High

Description

The product does not neutralize or incorrectly neutralizes user-controllable input before it is placed in output that is used as a web page that is served to other users.

Hierarchy (View 1000)

Related attack patterns (CAPEC)

CAPEC-209 · CAPEC-588 · CAPEC-591 · CAPEC-592 · CAPEC-63 · CAPEC-85

CVEs mapped to this weakness (48,564)

page 1028 of 2,429
  • CVE-2017-7430MedMay 3, 2017
    risk 0.40cvss 6.1epss 0.01

    Novell iManager 2.7.x before 2.7 SP7 Patch 10 HF1 and NetIQ iManager 3.x before 3.0.3.1 have a persistent XSS vulnerability in Framework.

  • CVE-2017-8384MedMay 1, 2017
    risk 0.40cvss 6.1epss 0.01

    Craft CMS before 2.6.2976 allows XSS attacks because an array returned by HttpRequestService::getSegments() and getActionSegments() need not be zero-based. NOTE: this vulnerability exists because of an incomplete fix for CVE-2017-8052.

  • CVE-2017-2151MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in Booking Calendar version 7.1 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2017-2147MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in WP Statistics version 12.0.4 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2017-2136MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.03

    Cross-site scripting vulnerability in WP Statistics version 12.0.4 and earlier allows remote attackers to inject arbitrary web script or HTML via specially crafted HTTP Referer headers.

  • CVE-2017-2135MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.02

    Cross-site scripting vulnerability in WP Statistics version 12.0.1 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2017-2134MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in ASSETBASE 8.0 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2017-2124MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in OneThird CMS v1.73 Heaven's Door and earlier allows remote attackers to inject arbitrary web script or HTML via contact.php.

  • CVE-2017-2123MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in OneThird CMS v1.73 Heaven's Door and earlier allows remote attackers to inject arbitrary web script or HTML via language.php.

  • CVE-2017-2118MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in WBCE CMS 1.1.10 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2017-2106MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.02

    Multiple cross-site scripting vulnerabilities in Webmin versions prior to 1.830 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

  • CVE-2016-7841MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in Olive Diary DX allows remote attackers to inject arbitrary web script or HTML via the page parameter.

  • CVE-2016-7840MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in WEB SCHEDULE allows remote attackers to inject arbitrary web script or HTML via the month parameter.

  • CVE-2016-7839MedApr 28, 2017
    risk 0.40cvss 6.1epss 0.01

    Cross-site scripting vulnerability in Olive Blog allows remote attackers to inject arbitrary web script or HTML via the search parameter.

  • CVE-2017-3008MedApr 27, 2017
    risk 0.40cvss 6.1epss 0.03

    Adobe ColdFusion 2016 Update 3 and earlier, ColdFusion 11 update 11 and earlier, ColdFusion 10 Update 22 and earlier have a reflected cross-site scripting vulnerability.

  • CVE-2017-3161MedApr 26, 2017
    risk 0.40cvss 6.1epss 0.04

    The HDFS web UI in Apache Hadoop before 2.7.0 is vulnerable to a cross-site scripting (XSS) attack through an unescaped query parameter.

  • CVE-2017-7987MedApr 25, 2017
    risk 0.40cvss 6.1epss 0.01

    In Joomla! 3.2.0 through 3.6.5 (fixed in 3.7.0), inadequate escaping of file and folder names leads to XSS vulnerabilities in the template manager component.

  • CVE-2017-7986MedApr 25, 2017
    risk 0.40cvss 6.1epss 0.01

    In Joomla! 1.5.0 through 3.6.5 (fixed in 3.7.0), inadequate filtering of specific HTML attributes leads to XSS vulnerabilities in various components.

  • CVE-2017-7985MedApr 25, 2017
    risk 0.40cvss 6.1epss 0.01

    In Joomla! 1.5.0 through 3.6.5 (fixed in 3.7.0), inadequate filtering of multibyte characters leads to XSS vulnerabilities in various components.

  • CVE-2017-7984MedApr 25, 2017
    risk 0.40cvss 6.1epss 0.01

    In Joomla! 3.2.0 through 3.6.5 (fixed in 3.7.0), inadequate filtering leads to XSS in the template manager component.