VYPR
Vendor

Erlang

Products
24
CVEs
77
Across products
167
Status
Private

Products

24

Recent CVEs

77
View all 77 CVEs →
  • CVE-2020-24719CriNov 12, 2020
    risk 0.69cvss 9.8epss 0.23

    Exposed Erlang Cookie could lead to Remote Command Execution (RCE) attack. Communication between Erlang nodes is done by exchanging a shared secret (aka "magic cookie"). There are cases where the magic cookie is included in the content of the logs. An attacker can use the cookie…

  • CVE-2022-37026CriSep 21, 2022
    risk 0.64cvss 9.8epss 0.01

    In Erlang/OTP before 23.3.4.15, 24.x before 24.3.4.2, and 25.x before 25.0.2, there is a Client Authentication Bypass in certain client-certification situations for SSL, TLS, and DTLS.

  • CVE-2020-13802CriSep 2, 2020
    risk 0.64cvss 9.8epss 0.07

    Rebar3 versions 3.0.0-beta.3 to 3.13.2 are vulnerable to OS command injection via URL parameter of dependency specification.

  • CVE-2026-28808CriApr 7, 2026
    risk 0.57cvss 9.8epss 0.01

    Incorrect Authorization vulnerability in Erlang OTP (inets modules) allows unauthenticated access to CGI scripts protected by directory rules when served via script_alias. When script_alias maps a URL prefix to a directory outside DocumentRoot, mod_auth evaluates…

  • CVE-2019-1000014HigFeb 4, 2019
    risk 0.57cvss 8.8epss 0.02

    Erlang/OTP Rebar3 version 3.7.0 through 3.7.5 contains a Signing oracle vulnerability in Package registry verification that can result in Package modifications not detected, allowing code execution. This attack appears to be exploitable via Victim fetches packages from…

  • CVE-2016-10253CriMar 18, 2017
    risk 0.57cvss 9.8epss 0.01

    An issue was discovered in Erlang/OTP 18.x. Erlang's generation of compiled regular expressions is vulnerable to a heap overflow. Regular expressions using a malformed extpattern can indirectly specify an offset that is used as an array index. This ordinal permits arbitrary…

  • CVE-2026-23941CriMar 13, 2026
    risk 0.54cvss 9.4epss 0.00

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Erlang OTP (inets httpd module) allows HTTP Request Smuggling. This vulnerability is associated with program files lib/inets/src/http_server/httpd_request.erl and program routines…

  • CVE-2026-89422CriSep 22, 2026
    risk 0.53cvss —epss 0.01

    Key Exchange without Entity Authentication vulnerability in Erlang/OTP ssl allows a peer that answers a TLS 1.3 client connection to impersonate the intended server. A pre_shared_key extension in the ServerHello that the client never offered causes the client to complete the…

  • CVE-2026-74835HigSep 1, 2026
    risk 0.50cvss —epss 0.01

    The inets application HTTP server httpd fails to enforce a configured body-size limit on chunked request. This issue affects OTP from OTP 17.0 before OTP 27.3.4.17, from OTP 28.0 before OTP 28.5.0.6, and from OTP 29.0 before OTP 29.0.6, corresponding to inets from 5.10…

  • CVE-2026-71380HigSep 1, 2026
    risk 0.50cvss —epss 0.01

    Missing Release of Resource after Effective Lifetime vulnerability in Erlang/OTP inets httpd allows an unauthenticated remote attacker to cause denial of service by sending valid request headers with a large Content-Length and then stalling before the body is complete. …

  • CVE-2026-70399HigSep 1, 2026
    risk 0.50cvss —epss 0.01

    Allocation of Resources Without Limits or Throttling vulnerability in Erlang/OTP inets httpd allows an unauthenticated remote attacker to cause denial of service by opening and holding open a large number of connections. The max_clients option is documented to default to 150,…

  • CVE-2026-69664HigSep 1, 2026
    risk 0.50cvss —epss 0.01

    Missing Release of Resource after Effective Lifetime vulnerability in Erlang/OTP inets httpd allows an unauthenticated remote attacker to cause denial of service by sending a request with a chunked body whose chunk-size line is not a hexadecimal number. The worker serving the…

  • CVE-2020-25623HigOct 2, 2020
    risk 0.49cvss 7.5epss 0.03

    Erlang/OTP 22.3.x before 22.3.4.6 and 23.x before 23.1 allows Directory Traversal. An attacker can send a crafted HTTP request to read arbitrary files, if httpd in the inets application is used.

  • CVE-2009-0130HigJan 15, 2009
    risk 0.49cvss 7.5epss 0.01

    lib/crypto/c_src/crypto_drv.c in erlang does not properly check the return value from the OpenSSL DSA_do_verify function, which might allow remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature, a similar vulnerability to CVE-2008-5077.…

  • CVE-2026-73812HigSep 1, 2026
    risk 0.47cvss —epss 0.01

    httpd function check_header/3 rejects duplicate Content-Length (per CVE-2026-23941) but never checks for the TE+CL co-presence that RFC 9112 §6.3 identifies as a probable smuggling attempt. handle_body/3 frames by chunked and silently discards Content-Length. A CL-preferring…

  • CVE-2026-73276HigSep 1, 2026
    risk 0.47cvss —epss 0.01

    Gracefulness code ignored cases that should be rejected, resulting in possible HTTP Request Smuggling opportunities. This issue affects OTP from OTP 22.2 before OTP 27.3.4.17, from OTP 28.0 before OTP 28.5.0.6, and from OTP 29.0 before OTP 29.0.6, corresponding to inets…

  • CVE-2026-66357HigSep 1, 2026
    risk 0.47cvss —epss 0.01

    httpd has never implemented obs-fold (RFC 2616 §2.2 / RFC 7230 §3.2.4 header continuation lines). Every CRLF followed by a non-CRLF octet unconditionally starts a new header. This missing feature became a security concern as the understanding of HTTP request smuggling attacks…

  • CVE-2026-59250HigJul 27, 2026
    risk 0.47cvss —epss 0.01

    Classic buffer overflow in the Erlang/OTP megaco flex scanner C driver allows a remote unauthenticated attacker to corrupt the driver's memory (and potentially achieve remote code execution or a denial-of-service crash) by sending a single text-encoded H.248/Megaco message…

  • CVE-2026-65634HigSep 22, 2026
    risk 0.46cvss —epss 0.00

    Inefficient algorithmic complexity in the Erlang/OTP asn1 OBJECT IDENTIFIER decoder allows a remote unauthenticated attacker to cause denial of service by sending a crafted OID during the TLS handshake. The BER OID decoder asn1rtt_ber:dec_subidentifiers/3 in…

  • CVE-2026-75538HigSep 1, 2026
    risk 0.46cvss —epss 0.01

    An attacker that connects to an open Erlang TCP port that uses the inet driver with {packet,4} mode can use a signed overflow in an incorrect packet length calculation to overflow the receive buffer into the VM allocator area and beyond up to about 2 GB. This would easily trash…