VYPR

rpm package

opensuse/squid&distro=openSUSE Tumbleweed

pkg:rpm/opensuse/squid&distro=openSUSE%20Tumbleweed

Vulnerabilities (68)

  • CVE-2026-50012MedJul 16, 2026
    affected < 7.7-2.1fixed 7.7-2.1

    Squid is a caching proxy for the Web. Prior to 7.6, due to an improper input validation bug in cache digest reply handling (peerDigestSwapInMask in src/peer_digest.cc), Squid is vulnerable to a heap-based buffer overflow: a cache digest's on-the-wire size may be larger than the m

  • CVE-2026-47729MedJul 16, 2026
    affected < 7.7-2.1fixed 7.7-2.1

    Squid is a caching proxy for the Web. Prior to 7.6, due to an improper validation of syntactic correctness of input in the FTP gateway (src/clients/FtpGateway.cc), Squid is vulnerable to an out-of-bounds read: when a listing entry date in the TypeA or TypeB directory-listing form

  • CVE-2026-33515MedMar 26, 2026
    affected < 7.7-2.1fixed 7.7-2.1

    Squid is a caching proxy for the Web. Prior to version 7.5, due to improper input validation, Squid is vulnerable to out of bounds read when handling ICP traffic. This problem allows a remote attacker to receive small amounts of memory potentially containing sensitive information

  • CVE-2025-62168CriOct 17, 2025
    affected < 7.3-1.1fixed 7.3-1.1

    Squid is a caching proxy for the Web. In Squid versions prior to 7.2, a failure to redact HTTP authentication credentials in error handling allows information disclosure. The vulnerability allows a script to bypass browser security protections and learn the credentials a trusted

  • CVE-2025-59362MedSep 26, 2025
    affected < 7.6-1.1fixed 7.6-1.1

    Squid through 7.1 mishandles ASN.1 encoding of long SNMP OIDs. This occurs in asn_build_objid in lib/snmplib/asn1.c.

  • CVE-2024-45802HigOct 28, 2024
    affected < 6.12-1.1fixed 6.12-1.1

    Squid is an open source caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to Input Validation, Premature Release of Resource During Expected Lifetime, and Missing Release of Resource after Effective Lifetime bugs, Squid is vulnerable to Denial of Service attack

  • CVE-2024-37894MedJun 25, 2024
    affected < 6.10-1.1fixed 6.10-1.1

    Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to an Out-of-bounds Write error when assigning ESI variables, Squid is susceptible to a Memory Corruption error. This error can lead to a Denial of Service attack.

  • CVE-2024-25111HigMar 6, 2024
    affected < 6.8-1.1fixed 6.8-1.1

    Squid is a web proxy cache. Starting in version 3.5.27 and prior to version 6.8, Squid may be vulnerable to a Denial of Service attack against HTTP Chunked decoder due to an uncontrolled recursion bug. This problem allows a remote attacker to cause Denial of Service when sending

  • CVE-2024-25617MedFeb 14, 2024
    affected < 6.8-1.1fixed 6.8-1.1

    Squid is an open source caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Collapse of Data into Unsafe Value bug ,Squid may be vulnerable to a Denial of Service attack against HTTP header parsing. This problem allows a remote client or a remote server to p

  • CVE-2024-23638MedJan 24, 2024
    affected < 6.6-2.1fixed 6.6-2.1

    Squid is a caching proxy for the Web. Due to an expired pointer reference bug, Squid prior to version 6.6 is vulnerable to a Denial of Service attack against Cache Manager error responses. This problem allows a trusted client to perform Denial of Service when generating error pag

  • CVE-2023-50269HigDec 14, 2023
    affected < 6.6-2.1fixed 6.6-2.1

    Squid is a caching proxy for the Web. Due to an Uncontrolled Recursion bug in versions 2.6 through 2.7.STABLE9, versions 3.1 through 5.9, and versions 6.0.1 through 6.5, Squid may be vulnerable to a Denial of Service attack against HTTP Request parsing. This problem allows a remo

  • CVE-2023-49288HigDec 4, 2023
    affected < 6.6-2.1fixed 6.6-2.1

    Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Affected versions of squid are subject to a a Use-After-Free bug which can lead to a Denial of Service attack via collapsed forwarding. All versions of Squid from 3.5 up to and including 5.9 configured wi

  • CVE-2023-49286HigDec 4, 2023
    affected < 6.6-2.1fixed 6.6-2.1

    Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to an Incorrect Check of Function Return Value bug Squid is vulnerable to a Denial of Service attack against its Helper process management. This bug is fixed by Squid version 6.5. Users are advised to

  • CVE-2023-49285HigDec 4, 2023
    affected < 6.6-2.1fixed 6.6-2.1

    Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Buffer Overread bug Squid is vulnerable to a Denial of Service attack against Squid HTTP Message processing. This bug is fixed by Squid version 6.5. Users are advised to upgrade. There are no kno

  • CVE-2023-5824HigNov 3, 2023
    affected < 6.4-1.1fixed 6.4-1.1

    A flaw was found in Squid. The limits applied for validation of HTTP response headers are applied before caching. However, Squid may grow a cached HTTP response header beyond the configured maximum size, causing a stall or crash of the worker process when a large header is retrie

  • CVE-2023-46848HigNov 3, 2023
    affected < 6.4-1.1fixed 6.4-1.1

    Squid is vulnerable to Denial of Service, where a remote attacker can perform DoS by sending ftp:// URLs in HTTP Request messages or constructing ftp:// URLs from FTP Native input.

  • CVE-2023-46847HigNov 3, 2023
    affected < 6.4-1.1fixed 6.4-1.1

    Squid is vulnerable to a Denial of Service, where a remote attacker can perform buffer overflow attack by writing up to 2 MB of arbitrary data to heap memory when Squid is configured to accept HTTP Digest Authentication.

  • CVE-2023-46846CriNov 3, 2023
    affected < 6.4-1.1fixed 6.4-1.1

    SQUID is vulnerable to HTTP request smuggling, caused by chunked decoder lenience, allows a remote attacker to perform Request/Response smuggling past firewall and frontend security systems.

  • CVE-2023-46724HigNov 1, 2023
    affected < 6.4-1.1fixed 6.4-1.1

    Squid is a caching proxy for the Web. Due to an Improper Validation of Specified Index bug, Squid versions 3.3.0.1 through 5.9 and 6.0 prior to 6.4 compiled using `--with-openssl` are vulnerable to a Denial of Service attack against SSL Certificate validation. This problem allows

  • CVE-2022-41318HigDec 25, 2022
    affected < 5.7-2.1fixed 5.7-2.1

    A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locatio

Page 1 of 4

VYPR — Vulnerability Intelligence