VYPR

Packagist (Composer) package

getgrav/grav

pkg:composer/getgrav/grav

Vulnerabilities (72)

  • CVE-2025-66296HigDec 1, 2025
    affected < 1.8.0-beta.27fixed 1.8.0-beta.27

    Grav is a file-based Web platform. Prior to 1.8.0-beta.27, a privilege escalation vulnerability exists in Grav’s Admin plugin due to the absence of username uniqueness validation when creating users. A user with the create user permission can create a new account using the same u

  • CVE-2025-66295HigDec 1, 2025
    affected < 1.8.0-beta.27fixed 1.8.0-beta.27

    Grav is a file-based Web platform. Prior to 1.8.0-beta.27, when a user with privilege of user creation creates a new user through the Admin UI and supplies a username containing path traversal sequences (for example ..\Nijat or ../Nijat), Grav writes the account YAML file to an u

  • CVE-2025-66294HigDec 1, 2025
    affected < 1.8.0-beta.27fixed 1.8.0-beta.27

    Grav is a file-based Web platform. Prior to 1.8.0-beta.27, a Server-Side Template Injection (SSTI) vulnerability exists in Grav that allows authenticated attackers with editor permissions to execute arbitrary commands on the server and, under certain conditions, may also be explo

  • CVE-2024-35498MedJan 6, 2025
    affected <= 1.7.45

    A cross-site scripting (XSS) vulnerability in Grav v1.7.45 allows attackers to execute arbitrary web scripts or HTML via a crafted payload.

  • CVE-2024-34082HigMay 15, 2024
    affected < 1.7.46fixed 1.7.46

    Grav is a file-based Web platform. Prior to version 1.7.46, a low privilege user account with page edit privilege can read any server files using Twig Syntax. This includes Grav user account files - `/grav/user/accounts/*.yaml`. This file stores hashed user password, 2FA secret,

  • CVE-2024-28119HigMar 21, 2024
    affected < 1.7.45fixed 1.7.45

    Grav is an open-source, flat-file content management system. Prior to version 1.7.45, due to the unrestricted access to twig extension class from grav context, an attacker can redefine the escape function and execute arbitrary commands. Twig processing of static pages can be enab

  • CVE-2024-28118HigMar 21, 2024
    affected < 1.7.45fixed 1.7.45

    Grav is an open-source, flat-file content management system. Prior to version 1.7.45, due to the unrestricted access to twig extension class from Grav context, an attacker can redefine config variable. As a result, attacker can bypass a previous SSTI mitigation. Twig processing o

  • CVE-2024-28117HigMar 21, 2024
    affected < 1.7.45fixed 1.7.45

    Grav is an open-source, flat-file content management system. Prior to version 1.7.45, Grav validates accessible functions through the Utils::isDangerousFunction function, but does not impose restrictions on twig functions like twig_array_map, allowing attackers to bypass the vali

  • CVE-2024-28116HigMar 21, 2024
    affected < 1.7.45fixed 1.7.45

    Grav is an open-source, flat-file content management system. Grav CMS prior to version 1.7.45 is vulnerable to a Server-Side Template Injection (SSTI), which allows any authenticated user (editor permissions are sufficient) to execute arbitrary code on the remote server bypassing

  • CVE-2024-27921HigMar 21, 2024
    affected < 1.7.45fixed 1.7.45

    Grav is an open-source, flat-file content management system. A file upload path traversal vulnerability has been identified in the application prior to version 1.7.45, enabling attackers to replace or create files with extensions like .json, .zip, .css, .gif, etc. This critical s

  • CVE-2024-27923HigMar 21, 2024
    affected < 1.7.43fixed 1.7.43

    Grav is a content management system (CMS). Prior to version 1.7.43, users who may write a page may use the `frontmatter` feature due to insufficient permission validation and inadequate file name validation. This may lead to remote code execution. Version 1.7.43 fixes this issue.

  • CVE-2023-31506MedFeb 9, 2024
    affected >= 0

    A cross-site scripting (XSS) vulnerability in Grav versions 1.7.44 and before, allows remote authenticated attackers to execute arbitrary web scripts or HTML via the onmouseover attribute of an ISINDEX element.

  • CVE-2023-37897HigJul 18, 2023
    affected < 1.7.42.2fixed 1.7.42.2

    Grav is a file-based Web-platform built in PHP. Grav is subject to a server side template injection (SSTI) vulnerability. The fix for another SSTI vulnerability using `|map`, `|filter` and `|reduce` twigs implemented in the commit `71bbed1` introduces bypass of the denylist due t

  • CVE-2023-34448HigJun 14, 2023
    affected < 1.7.42fixed 1.7.42

    Grav is a flat-file content management system. Prior to version 1.7.42, the patch for CVE-2022-2073, a server-side template injection vulnerability in Grav leveraging the default `filter()` function, did not block other built-in functions exposed by Twig's Core Extension that cou

  • CVE-2023-34253HigJun 14, 2023
    affected < 1.7.42fixed 1.7.42

    Grav is a flat-file content management system. Prior to version 1.7.42, the denylist introduced in commit 9d6a2d to prevent dangerous functions from being executed via injection of malicious templates was insufficient and could be easily subverted in multiple ways -- (1) using un

  • CVE-2023-34252HigJun 14, 2023
    affected < 1.7.42fixed 1.7.42

    Grav is a flat-file content management system. Prior to version 1.7.42, there is a logic flaw in the `GravExtension.filterFilter()` function whereby validation against a denylist of unsafe functions is only performed when the argument passed to filter is a string. However, passin

  • CVE-2023-34251CriJun 14, 2023
    affected < 1.7.42fixed 1.7.42

    Grav is a flat-file content management system. Versions prior to 1.7.42 are vulnerable to server side template injection. Remote code execution is possible by embedding malicious PHP code on the administrator screen by a user with page editing privileges. Version 1.7.42 contains

  • CVE-2022-2073HigJun 29, 2022
    affected < 1.7.34fixed 1.7.34

    Code Injection in GitHub repository getgrav/grav prior to 1.7.34.

  • CVE-2022-1173MedApr 26, 2022
    affected < 1.7.33fixed 1.7.33

    stored xss in GitHub repository getgrav/grav prior to 1.7.33.

  • CVE-2022-0970MedMar 15, 2022
    affected < 1.7.31fixed 1.7.31

    Cross-site Scripting (XSS) - Stored in GitHub repository getgrav/grav prior to 1.7.31.