VYPR

Bitnami package

discourse

pkg:bitnami/discourse

Vulnerabilities (287)

  • CVE-2023-40588MedSep 15, 2023
    affected < 3.1.1fixed 3.1.1

    Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, a malicious user could add a 2FA or security key with a carefully crafted name to their account and cause a denial of

  • CVE-2023-38706MedSep 15, 2023
    affected < 3.1.1fixed 3.1.1

    Discourse is an open-source discussion platform. Prior to version 3.1.1 of the `stable` branch and version 3.2.0.beta1 of the `beta` and `tests-passed` branches, a malicious user can create an unlimited number of drafts with very long draft keys which may end up exhausting the re

  • CVE-2023-38685MedJul 28, 2023
    affected < 3.0.6fixed 3.0.6

    Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, information about restricted-visibility topic tags could be obtained by unauthorized users. The issue is patched in ve

  • CVE-2023-38684MedJul 28, 2023
    affected < 3.0.6fixed 3.0.6

    Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, in multiple controller actions, Discourse accepts limit params but does not impose any upper bound on the values being

  • CVE-2023-38498MedJul 28, 2023
    affected < 3.0.6fixed 3.0.6

    Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can prevent the defer queue from proceeding promptly on sites hosted in the same multisite installati

  • CVE-2023-37906MedJul 28, 2023
    affected < 3.0.6fixed 3.0.6

    Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can edit a post in a topic and cause a DoS with a carefully crafted edit reason. The issue is patched

  • CVE-2023-37904LowJul 28, 2023
    affected < 3.0.6fixed 3.0.6

    Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, more users than permitted could be created from invite links. The issue is patched in version 3.0.6 of the `stable` br

  • CVE-2023-37467MedJul 28, 2023
    affected >= 1.1.0-beta1, <= 1.1.0-beta1

    Discourse is an open source discussion platform. Prior to version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a CSP (Content Security Policy) nonce reuse vulnerability was discovered could allow cross-site scripting (XSS) attacks to bypass CSP protection for anonymous

  • CVE-2023-36818MedJul 14, 2023
    affected >= 3.1.0-beta5, <= 3.1.0-beta5

    Discourse is an open source discussion platform. In affected versions a request to create or update custom sidebar section can cause a denial of service. This issue has been patched in commit `52b003d915`. Users are advised to upgrade. There are no known workarounds for this vuln

  • CVE-2023-36466LowJul 14, 2023
    affected < 3.0.5fixed 3.0.5

    Discourse is an open source discussion platform. When editing a topic, there is a vulnerability that enables a user to bypass the topic title validations for things like title length, number of emojis in title and blank topic titles. The issue is patched in the latest stable, bet

  • CVE-2023-36473MedJul 13, 2023
    affected < 3.0.5fixed 3.0.5

    Discourse is an open source discussion platform. A CSP (Content Security Policy) nonce reuse vulnerability could allow XSS attacks to bypass CSP protection. There are no known XSS vectors at the moment, but should one be discovered, this vulnerability would allow the XSS attack t

  • CVE-2023-34250MedJun 13, 2023
    affected < 3.0.4fixed 3.0.4

    Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, an attacker could use the new topics dismissal endpoint to reveal the number of topics recently created (but not the a

  • CVE-2023-32301LowJun 13, 2023
    affected < 3.0.4fixed 3.0.4

    Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, multiple duplicate topics could be created if topic embedding is enabled. This issue is patched in version 3.0.4 of th

  • CVE-2023-32061MedJun 13, 2023
    affected < 3.0.4fixed 3.0.4

    Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, the lack of restrictions on the iFrame tag makes it easy for an attacker to exploit the vulnerability and hide subsequ

  • CVE-2023-31142LowJun 13, 2023
    affected < 3.0.4fixed 3.0.4

    Discourse is an open source discussion platform. Prior to version 3.0.4 of the `stable` branch and version 3.1.0.beta5 of the `beta` and `tests-passed` branches, if a site has modified their general category permissions, they could be set back to the default. This issue is patche

  • CVE-2023-30606MedApr 18, 2023
    affected < 3.1.0fixed 3.1.0

    Discourse is an open source platform for community discussion. In affected versions a user logged as an administrator can call arbitrary methods on the `SiteSetting` class, notably `#clear_cache!` and `#notify_changed!`, which when done on a multisite instance, can affect the ent

  • CVE-2023-30538MedApr 18, 2023
    affected < 3.1.0fixed 3.1.0

    Discourse is an open source platform for community discussion. Due to the improper sanitization of SVG files, an attacker can execute arbitrary JavaScript on the users’ browsers by uploading a crafted SVG file. This issue is patched in the latest stable and tests-passed versions

  • CVE-2023-29196MedApr 18, 2023
    affected < 3.1.0fixed 3.1.0

    Discourse is an open source platform for community discussion. This vulnerability is not exploitable on the default install of Discourse. A custom feature must be enabled for it to work at all, and the attacker’s payload must pass the CSP to be executed. However, if an attacker s

  • CVE-2023-28440LowApr 18, 2023
    affected < 3.0.3fixed 3.0.3

    Discourse is an open source platform for community discussion. In affected versions a maliciously crafted request from a Discourse administrator can lead to a long-running request and eventual timeout. This has the greatest potential impact in shared hosting environments where ad

  • CVE-2023-28112MedMar 17, 2023
    affected < 3.1.0fixed 3.1.0

    Discourse is an open-source discussion platform. Prior to version 3.1.0.beta3 of the `beta` and `tests-passed` branches, some user provided URLs were being passed to FastImage without SSRF protection. Insufficient protections could enable attackers to trigger outbound network con

Page 11 of 15