rpm package
opensuse/qsnapper&distro=openSUSE Tumbleweed
pkg:rpm/opensuse/qsnapper&distro=openSUSE%20Tumbleweed
Vulnerabilities (5)
| CVE | Sev | CVSS | KEV | Affected versions | Fixed in | Published | Description |
|---|---|---|---|---|---|---|---|
| CVE-2026-41049 | Hig | 7.1 | < 1.3.3-1.4 | 1.3.3-1.4 | Jun 22, 2026 | Incorrect caching of authentication between different users of the qSnapper dbus service before version 1.3.3 allowed any local attacker to use dbus functions after a privileged users has authenticated for them. | |
| CVE-2026-41048 | Hig | 7.1 | < 1.3.3-1.4 | 1.3.3-1.4 | Jun 22, 2026 | Incorrect caching of authentication between different polkit methods in qSnapper before version 1.3.3 allowed a local attacker to use functions like "restore from snapshot" even if only allowed to do "delete snapshot". | |
| CVE-2026-41047 | Med | 5.5 | < 1.3.3-1.4 | 1.3.3-1.4 | Jun 22, 2026 | Lack of authentication when using the "snapshot diff" functions in qSnapper before version 1.3.3 allowed a local attacker to see otherwise read protected information. | |
| CVE-2026-41046 | Hig | 7.3 | < 1.3.3-1.4 | 1.3.3-1.4 | Jun 22, 2026 | A path traversal attack when using a "configName" parameter in qSnapper before version 1.3.3 allowed a local attacker to use malicious config files for snapper and so cause a denial of service or potentially escalate privileges to root. | |
| CVE-2026-41045 | Hig | 8.1 | < 1.3.3-1.4 | 1.3.3-1.4 | Jun 22, 2026 | A time-to-check-time-of-use in polkit authentication of qSnapper before version 1.3.3 allowed a local attacker to bypass qSnappers authentication mechanism and operate e.g. as root user. |
- affected < 1.3.3-1.4fixed 1.3.3-1.4
Incorrect caching of authentication between different users of the qSnapper dbus service before version 1.3.3 allowed any local attacker to use dbus functions after a privileged users has authenticated for them.
- affected < 1.3.3-1.4fixed 1.3.3-1.4
Incorrect caching of authentication between different polkit methods in qSnapper before version 1.3.3 allowed a local attacker to use functions like "restore from snapshot" even if only allowed to do "delete snapshot".
- affected < 1.3.3-1.4fixed 1.3.3-1.4
Lack of authentication when using the "snapshot diff" functions in qSnapper before version 1.3.3 allowed a local attacker to see otherwise read protected information.
- affected < 1.3.3-1.4fixed 1.3.3-1.4
A path traversal attack when using a "configName" parameter in qSnapper before version 1.3.3 allowed a local attacker to use malicious config files for snapper and so cause a denial of service or potentially escalate privileges to root.
- affected < 1.3.3-1.4fixed 1.3.3-1.4
A time-to-check-time-of-use in polkit authentication of qSnapper before version 1.3.3 allowed a local attacker to bypass qSnappers authentication mechanism and operate e.g. as root user.