VYPR

rpm package

opensuse/aspell&distro=openSUSE Tumbleweed

pkg:rpm/opensuse/aspell&distro=openSUSE%20Tumbleweed

Vulnerabilities (4)

  • CVE-2026-75820LowOct 6, 2026
    affected < 0.60.8.2-2.1fixed 0.60.8.2-2.1

    GNU Aspell contains an integer truncation vulnerability in the WritableDict::add() function in modules/speller/default/writable.cpp. When loading a personal wordlist, the word length is stored as a single byte, causing truncation for words whose length is a multiple of 256. This

  • CVE-2026-75819LowOct 6, 2026
    affected < 0.60.8.2-2.1fixed 0.60.8.2-2.1

    GNU Aspell contains an out-of-bounds read vulnerability in ReadOnlyDict::load() in readonly_ws.cpp. When loading a binary .rws dictionary file, it uses offset fields from the file header as byte indices into a heap buffer without validating their bounds. An attacker can trigger t

  • CVE-2026-75818LowOct 6, 2026
    affected < 0.60.8.2-2.1fixed 0.60.8.2-2.1

    GNU Aspell prezip-bin contains a heap-based buffer overflow vulnerability in the decompressor in prog/prezip.c. The decompressor does not properly check buffer space, so a crafted compressed file can cause out-of-bounds read and write operations on the heap. An attacker who convi

  • CVE-2019-25051HigJul 20, 2021
    affected < 0.60.8-4.2fixed 0.60.8-4.2

    objstack in GNU Aspell 0.60.8 has a heap-based buffer overflow in acommon::ObjStack::dup_top (called from acommon::StringMap::add and acommon::Config::lookup_list).