rpm package
almalinux/emacs-nw
pkg:rpm/almalinux/emacs-nw
Vulnerabilities (4)
| CVE | Sev | CVSS | KEV | Affected versions | Fixed in | Published | Description |
|---|---|---|---|---|---|---|---|
| CVE-2026-96442 | Hig | 7.8 | < 1:29.4-14.el10_2.3 | 1:29.4-14.el10_2.3 | Sep 23, 2026 | A code execution flaw was found in Emacs, affecting versions prior to 31.2. The Flymake mode using language backends other than Lisp would execute arbitrary code from the edited file while performing syntax checking. Viewing or editing untrusted files using Emacs could lead to ar | |
| CVE-2026-96269 | Hig | — | < 1:29.4-14.el10_2.4 | 1:29.4-14.el10_2.4 | Sep 22, 2026 | GNU Emacs 28.1 through 31.1 allows arbitrary code execution upon opening a file, because an untrusted value of read-symbol-shorthands affects the intern and unintern functions. This affects the default configuration; no particular user settings are required to trigger it. | |
| CVE-2026-79992 | Hig | 7.8 | < 1:29.4-14.el10_2.3 | 1:29.4-14.el10_2.3 | Aug 25, 2026 | A flaw was found in Emacs TRAMP. A local attacker could exploit this vulnerability by processing maliciously crafted filenames. This occurs because TRAMP concatenates login arguments without proper sanitization, which are then passed to a local shell. Successful exploitation coul | |
| CVE-2026-77219 | Hig | 7.1 | < 1:29.4-14.el10_2.3 | 1:29.4-14.el10_2.3 | Aug 21, 2026 | GNU Emacs before 31.0.91 contains an integer overflow in the PBM/PPM/PGM image loader that allows an attacker to leak heap memory contents by supplying a crafted image with large dimensions and an elevated max color index. The image loader multiplies image dimensions and channel |
- affected < 1:29.4-14.el10_2.3fixed 1:29.4-14.el10_2.3
A code execution flaw was found in Emacs, affecting versions prior to 31.2. The Flymake mode using language backends other than Lisp would execute arbitrary code from the edited file while performing syntax checking. Viewing or editing untrusted files using Emacs could lead to ar
- affected < 1:29.4-14.el10_2.4fixed 1:29.4-14.el10_2.4
GNU Emacs 28.1 through 31.1 allows arbitrary code execution upon opening a file, because an untrusted value of read-symbol-shorthands affects the intern and unintern functions. This affects the default configuration; no particular user settings are required to trigger it.
- affected < 1:29.4-14.el10_2.3fixed 1:29.4-14.el10_2.3
A flaw was found in Emacs TRAMP. A local attacker could exploit this vulnerability by processing maliciously crafted filenames. This occurs because TRAMP concatenates login arguments without proper sanitization, which are then passed to a local shell. Successful exploitation coul
- affected < 1:29.4-14.el10_2.3fixed 1:29.4-14.el10_2.3
GNU Emacs before 31.0.91 contains an integer overflow in the PBM/PPM/PGM image loader that allows an attacker to leak heap memory contents by supplying a crafted image with large dimensions and an elevated max color index. The image loader multiplies image dimensions and channel