VYPR

Bitnami package

pgbouncer

pkg:bitnami/pgbouncer

Vulnerabilities (14)

  • CVE-2026-107350HigOct 14, 2026
    affected >= 1.17.0, < 1.26.1fixed 1.26.1

    Improper authentication in PgBouncer 1.17.0 through 1.26.0 allows a remote attacker who knows the password of a user listed in auth_file to log in as any other user that authenticates using SCRAM, including PgBouncer admin users and backend superusers. A second StartupMessage sen

  • CVE-2026-107349HigOct 14, 2026
    affected >= 1.20.0, < 1.26.1fixed 1.26.1

    An infinite loop in PgBouncer 1.20.0 through 1.26.0 allows an unauthenticated remote attacker to cause a denial of service. A StartupMessage whose options parameter contains an empty parameter name, such as "-c=", makes the ignore_startup_parameters list lookup loop forever. Beca

  • CVE-2026-107348MedOct 14, 2026
    affected >= 1.21.0, < 1.26.1fixed 1.26.1

    Integer overflow in the message buffer growth logic (mbuf_make_room) in PgBouncer 1.21.0 through 1.26.0 allows a remote attacker to cause a denial of service when max_packet_size is configured above 2147483648. A packet header declaring a length above 2^31 makes the buffer size c

  • CVE-2026-6669MedSep 23, 2026
    affected < 1.26.0fixed 1.26.0

    Missing upper bound on the key derivation iteration count accepted during SCRAM authentication to a backend server in PgBouncer through 1.25.2 allows a malicious or compromised PostgreSQL backend to cause uncontrolled CPU consumption in PgBouncer. The resulting key derivation can

  • CVE-2026-6668HigSep 23, 2026
    affected < 1.26.0fixed 1.26.0

    Integer overflow in the packet buffer growth logic in PgBouncer through 1.25.2 allows an unauthenticated remote attacker to cause a denial of service. Sufficiently large input makes the buffer size computation overflow, leaving the growth loop unable to terminate. Because PgBounc

  • CVE-2026-19888HigSep 23, 2026
    affected < 1.26.0fixed 1.26.0

    Missing validation of a mandatory attribute in the SCRAM client-final-message parser in PgBouncer through 1.25.2 allows an unauthenticated remote attacker to crash the process. A malformed message can make the parser report success while leaving a required value unset, which is t

  • CVE-2026-6667MedMay 9, 2026
    affected < 1.25.2fixed 1.25.2

    PgBouncer before 1.25.2 did not perform an appropriate authorization check for the KILL_CLIENT admin command. All users with access to the administration console (which itself requires authorization) could run this command. It would have been correct to allow only users listed in

  • CVE-2026-6666MedMay 9, 2026
    affected < 1.25.2fixed 1.25.2

    A possible null pointer reference in PgBouncer before 1.25.2 could lead to a crash, if a server sends an error response without SQLSTATE field.

  • CVE-2026-6665HigMay 9, 2026
    affected < 1.25.2fixed 1.25.2

    The SCRAM code in PgBouncer before 1.25.2 did not check the return value of strlcat() correctly when building the contents of the SCRAM client-final-message. A malicious backend that sends a SCRAM server-final-message with a long nonce can trigger a stack overflow.

  • CVE-2026-6664HigMay 9, 2026
    affected < 1.25.2fixed 1.25.2

    An integer overflow in network packet parsing code in PgBouncer before 1.25.2 bypasses a boundary check and can lead to a crash. An unauthenticated remote attacker can crash PgBouncer with a malformed SCRAM authentication packet.

  • CVE-2025-12819HigDec 3, 2025
    affected < 1.25.1fixed 1.25.1

    Untrusted search path in auth_query connection handler in PgBouncer before 1.25.1 allows an unauthenticated attacker to execute arbitrary SQL during authentication via a malicious search_path parameter in the StartupMessage.

  • CVE-2025-2291HigApr 16, 2025
    affected < 1.24.1fixed 1.24.1

    Password can be used past expiry in PgBouncer due to auth_query not taking into account Postgres its VALID UNTIL value, which allows an attacker to log in with an already expired password

  • CVE-2021-3672MedNov 23, 2021
    affected < 1.17.1fixed 1.17.1

    A flaw was found in c-ares library, where a missing input validation check of host names returned by DNS (Domain Name Servers) can lead to output of wrong hostnames which might potentially lead to Domain Hijacking. The highest threat from this vulnerability is to confidentiality

  • CVE-2021-3935HigNov 22, 2021
    affected < 1.16.1fixed 1.16.1

    When PgBouncer is configured to use "cert" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.