VYPR

Bitnami package

nginx-gateway-fabric

pkg:bitnami/nginx-gateway-fabric

Vulnerabilities (8)

  • CVE-2026-96615MedOct 14, 2026
    affected >= 2.0.0, < 2.8.0fixed 2.8.0

    Description NGINX Gateway Fabric has a vulnerability when it is configured with Gateway Custom Resource Definition (CRD) and have an authenticated gRPC connection with NGINX Agent. A namespaced authenticated attacker with access to a service account may impersonate the authe

  • CVE-2026-91184HigOct 14, 2026
    affected >= 2.4.0, < 2.8.0fixed 2.8.0

    Description NGINX Gateway Fabric has a vulnerability when it renders the spec.basic.realm (and spec.jwt.realm) field of a namespaced AuthenticationFilter verbatim, unescaped and unvalidated, into the shared data-plane nginx.conf as auth_basic "";. A namespaced authenticat

  • CVE-2026-66362HigSep 2, 2026
    affected >= 2.5.0, < 2.6.8fixed 2.6.8

    Description: When NGINX Plus is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the Authentication Filter Custom Resource Definition c

  • CVE-2026-50107HigJun 17, 2026
    affected >= 2.3.0, < 2.6.4fixed 2.6.4

    When NGINX Plus or NGINX Open Source is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the NginxProxy Custom Resource Definition (CRD

  • CVE-2026-32682MedJun 17, 2026
    affected >= 1.3.0, < 2.6.4fixed 2.6.4

    When NGINX Gateway Fabric is configured using GRPCRoutes, an authenticated, remote attacker with permission to create or modify GRPCRoute resources can cause the NGINX Gateway Fabric control plane to terminate by sending undisclosed GRPCRoute configurations containing backendRef

  • CVE-2026-48142MedJun 17, 2026
    affected >= 1.3.0, < 2.6.4fixed 2.6.4

    NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_charset_module module. When content is served or proxied through a location block with both source_charset utf-8; and a charset directive (for example, charset koi8-r;) configured, remote, unauthenticated attac

  • CVE-2026-42055HigJun 17, 2026
    affected >= 1.3.0, < 2.6.4fixed 2.6.4

    NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_proxy_v2_module and ngx_http_grpc_module modules. This vulnerability exists when the proxy_http_version to 2 or grpc_pass directives are used to proxy HTTP/2 traffic, the ignore_invalid_headers directive is set

  • CVE-2026-11311HigJun 17, 2026
    affected >= 2.5.0, < 2.6.4fixed 2.6.4

    When NGINX Plus is configured as the data plane for NGINX Gateway Fabric, an injection vulnerability exists in the NGINX configuration generator component of NGINX Gateway Fabric. User-supplied string values from the NginxProxy Custom Resource Definition serverTokens field and th