Low severity3.3NVD Advisory· Published Sep 18, 2026· Updated Oct 29, 2026
CVE-2026-93587
CVE-2026-93587
Description
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Affected products
4cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:*+ 1 more
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:*range: <6.9.13-56
- (no CPE)range: <7.1.2-31, <6.9.13-56
- osv-coords2 versionspkg:rpm/opensuse/ImageMagick&distro=openSUSE%20Leap%2016.0pkg:rpm/opensuse/ImageMagick&distro=openSUSE%20Tumbleweed
< 7.1.2.0-160000.16.1+ 1 more
- (no CPE)range: < 7.1.2.0-160000.16.1
- (no CPE)range: < 7.1.2.31-2.1
Patches
Vulnerability mechanics
References
2- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-89wq-f8f6-2j2vnvdVendor Advisory
- www.vulncheck.com/advisories/imagemagick-before-7.1.2-31-policy-bypass-via-pcd-decodernvdThird Party Advisory
News mentions
0No linked articles in our index yet.