Low severity2.9NVD Advisory· Published Sep 18, 2026· Updated Oct 29, 2026
CVE-2026-93586
CVE-2026-93586
Description
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a use-after-free vulnerability in the ImagesToBlob method, caused by a pointer that is not updated correctly. Exploitation may result in a limited availability impact (e.g., a crash of the affected process). The issue is fixed in versions 7.1.2-31 and 6.9.13-56.
Affected products
4<7.1.2-31, <6.9.13-56+ 1 more
- (no CPE)range: <7.1.2-31, <6.9.13-56
- cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:*range: <6.9.13-56
- osv-coords2 versionspkg:rpm/opensuse/ImageMagick&distro=openSUSE%20Tumbleweedpkg:rpm/opensuse/ImageMagick&distro=openSUSE%20Leap%2016.0
< 7.1.2.31-2.1+ 1 more
- (no CPE)range: < 7.1.2.31-2.1
- (no CPE)range: < 7.1.2.0-160000.16.1
Patches
Vulnerability mechanics
References
2- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-3rjr-534c-8v67nvdVendor Advisory
- www.vulncheck.com/advisories/imagemagick-before-7.1.2-31-use-after-free-via-imagestoblobnvdThird Party Advisory
News mentions
0No linked articles in our index yet.