CVE-2026-92958
Description
vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM. When the embedder uses the builtin wildcard together with negative entries (e.g. require: { builtin: ['*', '-fs', '-child_process'] }), negative entries are matched by exact module name in lib/builtin.js, so -fs removes only the builtin named fs and does not remove builtin subpaths such as fs/promises. Sandboxed code can therefore call require('fs/promises') or require('node:fs/promises') and reach the promise-based filesystem API despite fs being denied; node: prefix handling is likewise inconsistent (a -node:fs/promises entry does not block require('fs/promises')). Host file creation and writing were confirmed via fsp.writeFile(), and other fs/promises operations (cp, mkdir, rename, rm, rmdir, truncate, read operations, etc.) are also reachable. This issue is fixed in vm2 3.11.7.
AI Insight
LLM-synthesized narrative grounded in this CVE's description and references.
Affected packages
Versions sourced from the GitHub Security Advisory.
| Package | Affected versions | Patched versions |
|---|---|---|
vm2npm | < 3.11.7 | 3.11.7 |
Affected products
2- Range: 3.11.6, v3.11.5, v3.11.4, …
Patches
Vulnerability mechanics
References
6- github.com/advisories/GHSA-6rh5-qq4q-97xhghsaADVISORY
- nvd.nist.gov/vuln/detail/CVE-2026-92958ghsaADVISORY
- github.com/patriksimek/vm2/commit/59d35f68e52a9bd229a8a72bcd9274bd4cec2bc5ghsaWEB
- github.com/patriksimek/vm2/releases/tag/v3.11.7ghsaWEB
- github.com/patriksimek/vm2/security/advisories/GHSA-6rh5-qq4q-97xhnvdWEB
- www.vulncheck.com/advisories/vm2-before-3.11.7-denylist-bypass-via-fs-promisesnvdWEB
News mentions
1- vm2 npm Package: 25 Critical Sandbox Escape Vulnerabilities Disclosed TogetherVypr Intelligence · Sep 18, 2026