CVE-2026-92948
Description
vm2 versions >= 3.9.6 and <= 3.11.6 are affected by a NodeVM builtin allowlist bypass that permits a sandbox escape on Node.js 24 and newer when the embedder explicitly allows the node:test builtin (e.g. require: { builtin: ['node:test'] }). On Node.js 24+, module.builtinModules exposes the scheme-only key node:test, which is not covered by vm2's family-based DANGEROUS_BUILTINS protection, so it is stored in the generic host-passthrough loader. Because requireImpl() in lib/setup-node-sandbox.js strips a single 'node:' prefix before the builtin lookup, sandbox code calling require('node:node:test') resolves to the stored node:test key and receives a readonly proxy to the host module. Calls to node:test.run() are forwarded to the host implementation, which spawns a separate Node process for process-isolated test execution and passes through attacker-controlled execArgv values; supplying --eval= therefore executes arbitrary JavaScript in an unrestricted host Node process outside the NodeVM sandbox. Fixed in vm2 3.11.7.
AI Insight
LLM-synthesized narrative grounded in this CVE's description and references.
Affected packages
Versions sourced from the GitHub Security Advisory.
| Package | Affected versions | Patched versions |
|---|---|---|
vm2npm | >= 3.9.6, < 3.11.7 | 3.11.7 |
Affected products
2- Range: 3.11.6, v3.11.5, v3.11.4, …
Patches
Vulnerability mechanics
References
6- github.com/advisories/GHSA-qhwx-74w5-xhxqghsaADVISORY
- nvd.nist.gov/vuln/detail/CVE-2026-92948ghsaADVISORY
- github.com/patriksimek/vm2/commit/415339f698f0d52d3c5ad358b12b79c8072d5b4bghsaWEB
- github.com/patriksimek/vm2/releases/tag/v3.11.7ghsaWEB
- github.com/patriksimek/vm2/security/advisories/GHSA-qhwx-74w5-xhxqnvdWEB
- www.vulncheck.com/advisories/vm2-3.9.6-through-3.11.5-sandbox-escape-via-node-testnvdWEB
News mentions
1- vm2 npm Package: 25 Critical Sandbox Escape Vulnerabilities Disclosed TogetherVypr Intelligence · Sep 18, 2026