CVE-2026-92935
Description
vm2 is a sandbox for running untrusted Node.js code. In versions >= 3.11.4 and <= 3.11.6, the NodeVM constructor computes hasRealRequireConfig with typeof requireOpts === 'object' && requireOpts !== null, so an array-shaped require value (for example require: []) satisfies the guard that is meant to reject nesting without an explicit require configuration. makeResolverFromLegacyOptions() then destructures the array into undefined option fields and returns a resolver containing only NESTING_OVERRIDE.vm2. As a result, an attacker who can supply JavaScript executed by a NodeVM configured with truthy nesting and an array-shaped require (e.g. new NodeVM({nesting: true, require: []})) can require the host vm2 module, create an inner NodeVM with an attacker-chosen builtin allowlist (such as child_process), and execute arbitrary commands with the privileges of the host Node.js process, escaping the sandbox. Outer builtin restrictions do not constrain the attacker-created inner NodeVM. This issue is fixed in vm2 3.11.7.
Affected packages
Versions sourced from the GitHub Security Advisory.
| Package | Affected versions | Patched versions |
|---|---|---|
vm2npm | >= 3.11.4, < 3.11.7 | 3.11.7 |
Affected products
2Patches
Vulnerability mechanics
References
7- github.com/advisories/GHSA-8hr7-r645-pc6wghsaADVISORY
- nvd.nist.gov/vuln/detail/CVE-2026-92935ghsaADVISORY
- github.com/patriksimek/vm2/commit/05894eca1dc6a2b1a986f312c88255288a983d22ghsaWEB
- github.com/patriksimek/vm2/commit/54b54b74a382577f0bcd0538c5bf99acdcd7f53bnvdWEB
- github.com/patriksimek/vm2/releases/tag/v3.11.7ghsaWEB
- github.com/patriksimek/vm2/security/advisories/GHSA-8hr7-r645-pc6wnvdWEB
- www.vulncheck.com/advisories/vm2-nodevm-remote-code-execution-via-array-shaped-requirenvdWEB
News mentions
1- vm2 npm Package: 25 Critical Sandbox Escape Vulnerabilities Disclosed TogetherVypr Intelligence · Sep 18, 2026