VYPR
Unrated severityNVD Advisory· Published Oct 28, 2026

CVE-2026-83525

CVE-2026-83525

Description

Incorrect operator (CWE-480) in the FetchSnapshot RPC handler in Apache Kafka from 2.8.0 before 4.2.2, and from 4.3.0 before 4.3.2 on all platforms allows an authenticated attacker with CLUSTER_ACTION privilege to cause a denial of service (controller process termination) via a crafted FetchSnapshotRequest with an empty topics array or a topic with no partitions.

Users are recommended to upgrade to version 4.2.2, 4.3.2, or 4.4.0, which fix this issue. Users on unsupported branches (4.1.x and earlier) should upgrade to 4.2.2 or later.

AI Insight

LLM-synthesized narrative grounded in this CVE's description and references.

Affected products

1
  • Apache/Kafkallm-fuzzy
    Range: 2.8.0 - 4.2.1, 4.3.0 - 4.3.1

Patches

Vulnerability mechanics

References

2

News mentions

0

No linked articles in our index yet.