VYPR
Critical severityNVD Advisory· Published Sep 17, 2026· Updated Sep 30, 2026

CVE-2026-79752

CVE-2026-79752

Description

CakePHP is a rapid development framework for PHP. Prior to 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7, FunctionsBuilder::cast, FunctionsBuilder::extract, FunctionsBuilder::datePart, and FunctionsBuilder::dateAdd in src/Database/FunctionsBuilder.php accept user-controlled dataType, part, or unit values and incorporate them into generated SQL as unescaped structural fragments. An application that passes untrusted input to these parameters can permit SQL injection with confidentiality, integrity, and availability impact according to the database connection's privileges. This issue is fixed in versions 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7.

Affected packages

Versions sourced from the GitHub Security Advisory.

PackageAffected versionsPatched versions
cakephp/databasePackagist
>= 3.0.0, < 4.5.124.5.12
cakephp/databasePackagist
>= 4.6.0, < 4.6.54.6.5
cakephp/databasePackagist
>= 5.0.0, < 5.1.95.1.9
cakephp/databasePackagist
>= 5.2.0, < 5.2.145.2.14
cakephp/databasePackagist
>= 5.3.0, < 5.3.75.3.7
cakephp/cakephpPackagist
< 4.5.124.5.12
cakephp/cakephpPackagist
>= 4.6.0, < 4.6.54.6.5
cakephp/cakephpPackagist
>= 5.0.0, < 5.1.95.1.9
cakephp/cakephpPackagist
>= 5.2.0, < 5.2.145.2.14
cakephp/cakephpPackagist
>= 5.3.0, < 5.3.75.3.7

Affected products

1
  • Cakephp/Cakephpllm-fuzzy
    Range: before 4.5.12, 4.6.5, 5.1.9, 5.2.14, and 5.3.7

Patches

Vulnerability mechanics

References

17

News mentions

0

No linked articles in our index yet.