VYPR
Critical severity9.8NVD Advisory· Published Aug 7, 2026· Updated Oct 23, 2026

CVE-2026-71558

CVE-2026-71558

Description

Heap type confusion vulnerability in Apache Fory C++ deserialization.

This issue affects Apache Fory C++ versions from 0.14.0 before 1.5.0. A crafted input payload can bypass type compatibility checks during polymorphic smart-pointer deserialization, causing an object of an incompatible type to be treated as the declared base type. This may result in undefined behavior and potentially lead to denial of service or arbitrary code execution.

Users are recommended to upgrade to Apache Fory 1.5.0, which fixes this issue. Applications not using Apache Fory C++ polymorphic smart-pointer deserialization are not affected.

AI Insight

LLM-synthesized narrative grounded in this CVE's description and references.

Affected products

3
  • Apache/Fory C++llm-fuzzy
    Range: <1.5.0
  • Apache/Foryllm-fuzzy2 versions
    <1.5.0+ 1 more
    • (no CPE)range: <1.5.0
    • cpe:2.3:a:apache:fory:*:*:*:*:*:*:*:*range: >=0.14.0,<1.5.0

Patches

Vulnerability mechanics

References

2

News mentions

1