VYPR
Medium severity6.1NVD Advisory· Published Aug 3, 2026· Updated Aug 11, 2026

CVE-2026-69151

CVE-2026-69151

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.1, the Angular compiler i18n pipeline permits i18n-onerror and other i18n-on event-handler attributes, allowing a lower-trust translation file to replace a static handler with executable JavaScript. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.1.

AI Insight

LLM-synthesized narrative grounded in this CVE's description and references.

Affected packages

Versions sourced from the GitHub Security Advisory.

PackageAffected versionsPatched versions
@angular/compilernpm
>= 22.0.0-next.0, < 22.0.122.0.1
@angular/compilernpm
>= 21.0.0-next.0, < 21.2.1921.2.19
@angular/compilernpm
>= 20.0.0-next.0, < 20.3.2720.3.27
@angular/compilernpm
<= 19.2.25—
@angular/corenpm
>= 22.0.0-next.0, < 22.0.122.0.1
@angular/corenpm
>= 21.0.0-next.0, < 21.2.1921.2.19
@angular/corenpm
>= 20.0.0-next.0, < 20.3.2720.3.27
@angular/corenpm
<= 19.2.25—

Affected products

2
  • Angular/Angularllm-fuzzy2 versions
    <20.3.27, <21.2.19, <22.0.1+ 1 more
    • (no CPE)range: <20.3.27, <21.2.19, <22.0.1
    • cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:*range: <=19.2.25

Patches

Vulnerability mechanics

References

6

News mentions

0

No linked articles in our index yet.