High severity7.4NVD Advisory· Published Sep 23, 2026· Updated Oct 19, 2026
CVE-2026-67404
CVE-2026-67404
Description
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
AI Insight
LLM-synthesized narrative grounded in this CVE's description and references.
Affected products
3- cpe:2.3:a:broadcom:rabbitmq_server:*:*:*:*:*:*:*:*Range: >=3.13.0,<3.13.15
- Range: <3.13.15, <4.0.20, <4.1.11, <4.2.6, <4.3.0
Patches
Vulnerability mechanics
References
2- github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-37wx-r6q9-6fhjnvdVendor Advisory
- github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6nvdRelease Notes
News mentions
1- RabbitMQ Server: 22 Vulnerabilities Disclosed Together, Ranging from Critical to Low SeverityVypr Intelligence · Sep 23, 2026