Low severity3.7NVD Advisory· Published Nov 5, 2026
CVE-2026-61813
CVE-2026-61813
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 2.9.15 and 3.0.17, the HttpsClient::download function in src/utils/https_client.cc sets libcurl CURLOPT_SSL_VERIFYHOST to 1 instead of the strict value 2L. Under adversary-in-the-middle and TLS interception conditions, this non-strict setting may weaken TLS peer identity validation and increase the risk of accepting a certificate for an unintended host. End-to-end exploitation is non-trivial in typical environments. This issue is fixed in versions 2.9.15 and 3.0.17.
Affected products
1- Range: <2.9.15 and <3.0.17
Patches
Vulnerability mechanics
References
5- github.com/owasp-modsecurity/ModSecurity/commit/cce204806430e4848327aadeb9113e654631a0c1nvd
- github.com/owasp-modsecurity/ModSecurity/commit/edca70d853bfb725325137fa40d178beebc324fcnvd
- github.com/owasp-modsecurity/ModSecurity/releases/tag/v2.9.15nvd
- github.com/owasp-modsecurity/ModSecurity/releases/tag/v3.0.17nvd
- github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-2vqc-36qp-ccmwnvd
News mentions
0No linked articles in our index yet.