Medium severity5.9NVD Advisory· Published Jul 29, 2026· Updated Oct 1, 2026
CVE-2026-58158
CVE-2026-58158
Description
Apache Traffic Server mishandles PROXY protocol input, truncating ports and overflowing the stack.
This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3.
Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Affected products
2from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3+ 1 more
- (no CPE)range: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3
- cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*range: >=8.0.0,<=8.1.9
Patches
Vulnerability mechanics
References
1- lists.apache.org/thread/5prl9glcm9g2swnq9hqxvnokylm1gr6dnvdMailing ListVendor Advisory
News mentions
0No linked articles in our index yet.