Unrated severityNVD Advisory· Published Oct 28, 2026
CVE-2026-116593
CVE-2026-116593
Description
Apache Kafka Connect has the /connector-plugins/{connector-type}/config/validate endpoint on its REST API to validate connector configurations. Apache Kafka Connect also support Configuration Providers which enable to hide the values of sensitive configuration and only resolve them at runtime.
An attacker with access to the validate endpoint can use it to resolve and return plaintext values via any of the configuration providers installed on a Connect worker.
Users are recommended to upgrade to version 4.2.2, 4.3.2, 4.4.0 or above, which fix this issue.
Affected products
1- Range: >=4.2.2, >=4.3.2, >=4.4.0
Patches
Vulnerability mechanics
References
1News mentions
0No linked articles in our index yet.